HDU--5327 Olympiad

Olympiad

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 347    Accepted Submission(s): 257


Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval [a,b] (ab) . Please be fast to get the gold medal!
 

Input
The first line of the input is a single integer T (T1000) , indicating the number of testcases.

For each test case, there are two numbers a and b , as described in the statement. It is guaranteed that 1ab100000 .
 

Output
For each testcase, print one line indicating the answer.
 

Sample Input
  
  
2 1 10 1 1000
 

Sample Output
  
  
10 738
 

Author
XJZX
 

Source
2015 Multi-University Training Contest 4


本题就是关于判定一个数中是否包含有有重复的数字并求出一个区间内满足条件 的书的个数;
暴搜超时,每一个区间都算一遍浪费时间,直接先算出每一个数字之前满足条件的数字个数即可,打表法
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int temp[10];
int ans[100001];
int i,j,n,a,b;

int fun1(int x)//用于判断数字是否满足条件
{
    int mod;
    memset(temp,0,sizeof(temp));
    while(x != 0)
    {
        mod = x % 10;
        if(temp[mod])
        {
            return 0;
        }
        else
        {
            temp[mod]++;
        }
        x /= 10;
    }
    return 1;
}
int main()
{
    //结果打表
    for(i = 1;i < 100001;i++)
    {
        if(fun1(i))
        {
            ans[i] = ans[i-1] + 1;
        }
        else
        {
            ans[i] = ans[i-1];
        }
    }

    scanf("%d",&n);
    for(i = 0;i < n;i++)
    {
        scanf("%d%d",&a,&b);
        printf("%d\n",ans[b] - ans[a] + fun1(a));//区间相减即可
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值