Piggy-Bank—hdu1114完全背包

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19651    Accepted Submission(s): 9975


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 

Sample Input
  
  
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
  
  
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
给出背包大小和物品大小与价值,求装满背包时的最小价值;

二维写法:

设dp[i][j]为:在选择第i种物品时,刚好装满大小为j的背包的最小价值

w[i]:第i中物品的大小

v[i]:第i种物品的价值

状态转移方程:当w[i]>j,即大小为j的背包装不下一个第i种物品,则有: dp[i][j] = dp[i - 1][j];即第i种物品一个也不放

当w[i] <= j,即大小为j的背包能装下至少一个第i种物品,则有:dp[i][j] = min(dp[i - 1][j],dp[i][j - w[i]] + v[i]]);即在 放入一个第i种物品和不放入i种物品中选择一个最小值

这里的第二种情况可能不太好理解,因为从方程中看似乎只考虑了放入一个第i种物品的情况,但是要知道j是逐渐变大的,只要j的上限不止能放下一个第i种物品,就会逐渐叠加第i种物品的数量;

因为是求最小值,所以数组的初始化除了dp[i][0]为0之外都是INF

不能理解的手动画一个表模拟一下好好体会过程

#include<iostream>
#include<cstdio>
#include<cstring>
#define INF 0x7ffffff
using namespace std;
int dp[500][10000];
int v[505];
int w[505];
int min_dp(int n,int b)
{
    for(int i = 0; i <= n; i++) {
        for(int j = 0;j <= b;j++){
            if(i == 0 && j != 0)
                dp[i][j] = INF;
            else if(i != 0&& j == 0)
                dp[i][j] = 0;
            else dp[i][j] =  INF;
        }
    }
    for(int i = 1;i <= n;i++)
    {
        for(int j = 1;j <= b;j++)
        {
            if(w[i] > j)
                dp[i][j] = dp[i - 1][j];
            else
               {
                   dp[i][j] =min(dp[i - 1][j],dp[i][j - w[i]] + v[i]);
               }
        }
    }
    return 0;
}

int main()
{
    int t,n,e,f,b;
    scanf("%d",&t);
    while(t--) {
        memset(v,0,sizeof(v));
        memset(w,0,sizeof(w));
        memset(dp,0,sizeof(dp));
        scanf("%d%d%d",&e,&f,&n);
        b = f - e;
        for(int i =1 ; i<= n; i++) {
            scanf("%d%d",&v[i],&w[i]);
        }
        min_dp(n,b);
        if(dp[n][b] == INF) printf("This is impossible.\n");
        else printf("The minimum amount of money in the piggy-bank is %d.\n",dp[n][b]);
    }
    return 0;
}
一维写法:

设dp[i]为恰好装满大小为i的背包实现的最小价值

状态方程:如果w>i,即大小为i的背包装不下当前的物品,则dp[i]背包保持状态不变;

如果w<=i,即大小为i的背包能装下当前的物品,则有 : dp[i] = min(dp[i],dp[i - w] + v);即在 装下当前物品和不装当前物品中选择一个最小值;

同二维写法一样,第二种情况会随着i的变大而逐渐考虑加入多个当前物品的情况;

数组的初始化除0之外都为INF

#include<iostream>
#include<cstdio>
#include<cstring>
#define INF 0x7ffffff
using namespace std;
int dp[10005];
int main()
{
    int t,n,e,f,cap,w,v;
    scanf("%d",&t);
    while(t--) {
        scanf("%d%d%d",&e,&f,&n);
        cap = f - e;
        for(int i = 1;i <=cap;i++){//只需要初始化cap大小的背包
            dp[i] = INF;
        }
        dp[0] = 0;
        for(int j =1 ; j<= n; j++) {
            scanf("%d%d",&v,&w);
            for(int i = 1;i <= cap;i++){
                if(i >= w){
                    dp[i] = min(dp[i],dp[i - w] + v);
                }
            }
        }
        if(dp[cap] == INF) printf("This is impossible.\n");
        else printf("The minimum amount of money in the piggy-bank is %d.\n",dp[cap]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值