KMP_match(next)数组求字符串循环

Period

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题目出处HDU 1358

题意:求字符串S[i-k](1<=k<=n)是否为周期串,若是,打印最大循环次数和对应循环节长度。

分析:

记字符串S,由KMP的match数组的性质,我们知道match数组存储的是当前字符i中,S[1-i]的真前后缀能匹配到的真前缀的末尾字符,考虑如果字符串S[1-i]是循环的,那么必有match[i]>=(i/2),因为循环节>=2,若循环节为2,那么match[i]=i/2,若>2,那么match[i]为i-最小循环节长度,必定>i/2。

然后考虑S[1-i]是循环的情况,题目所求为最大循环次数,那么对应的最小循环节,最小循环节长度就是i-match[i](画个图就很容易看出来)(这时候match[i]一定>=i/2)然后就求完了。

#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int const maxn=1e6+10;
char w[maxn];
int match[maxn],i,j,k=1;
int main(void)
{
    while(k++)//记录case次数 
    {
    	int n;
    	scanf("%d",&n);
    	if(n==0)
    	return 0;
    	scanf("%s",w);
    	match[0]=-1;
    	for(j=1;j<n;j++)//求match数组 
    	{
    		i=match[j-1];//先记录一下j-1已经匹配上的字符段末尾 
    		while(i>=0&&w[i+1]!=w[j])//如果没匹配上就回溯 
    		i=match[i];
    		if(w[i+1]==w[j])
    		match[j]=i+1;//记录match 
    		else
    		match[j]=-1;
		}
		printf("Test case #%d\n",k-1);
		for(int i=0;i<n;i++)//注意i是数组下标,从0开始,所以下面在求循环节和循环次数的时候要+1 
		{
			if(((i+1)%((i+1)-(match[i]+1))==0)&&match[i]!=-1)//判断是否为循环字符串 
			printf("%d %d\n",i+1,(i+1)/((i+1)-(match[i]+1)));
		}
		printf("\n");
	}
	return 0;
}

2021.8.2

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值