upc7224 Problem J The puzzle

题目描述

Kayaking is playing a puzzle game containing n different blocks. He marks the blocks with integers from 1 to n, which show the blocks’ original positions. Each time he can exchange two blocks and he wants to know how many times he needs at least to restore the puzzle.

 

输入

The input starts with one line contains exactly one positive integer T which is the number of test cases.
Each test case contains two lines.
The first line contains an integer, which indicates the number of puzzle pieces.
The second line contains n different integers, the i-th number means the mark of the block in the i-th position.

 

输出

For each test case, output one line with one number represents the minimum operations.

 

样例输入

2
4
2 3 4 1
4
2 1 4 3

 

样例输出

3
2

提示

1≤T≤20,1≤n≤100000

题意:有从1——n共n个数,排序,每次操作更换两个数的位置,求最少操作次数,使得排序为从1——n。

思路:找到每个数应该在的位置,标记。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int a[100010];
        int vis[100010]={0};
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int res=0;
        for(int i=1;i<=n;i++)
        {
            int tmp=a[i],cnt=0;
            while(!vis[tmp])
            {
                vis[tmp]=1;
                tmp=a[tmp];
                cnt++;
            }
            if(cnt>0)
                res+=(cnt-1);
        }
        printf("%d\n",res);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值