ACM 数论 hdu 1395 2^x mod n = 1

Problem Description
Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.
 

Input
One positive integer on each line, the value of n.
 

Output
If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.
 

Sample Input
  
  
2 5
 

Sample Output
  
  
2^? mod 2 = 1 2^4 mod 5 = 1




这道题数据简单,暴力求解可以出来,但真要用思维做,需要用到欧拉函数,在此先不用了

但是注意,当x为1或者偶数时,是绝对不可能实现的,首先pass

其余的进行暴力求解法即可

  1. #include<stdio.h>  
  2.   
  3. int main(){  
  4.     int x,n,t;  
  5.     while(scanf("%d",&n)!=EOF){  
  6.         if(n==1 || n%2==0)
  7.       {  
  8.            
  9.             printf("2^? mod %d = 1\n",n);  
  10.         }
  11.       else
  12.     {  
  13.             x=1;  
  14.             t=2;  
  15.         
  16.             while(t%n!=1){  
  17.                 x++;  
  18.                 t=t*2%n;     //反之数值过大
  19.             }  
  20.             printf("2^%d mod %d = 1\n",x,n);  
  21.         }  
  22.     }      
  23.     return 0;  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值