POJ2559——Largest Rectangle in a Histogram(栈的应用)

Largest Rectangle in a Histogram
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19094 Accepted: 6140

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer  n, denoting the number of rectangles it is composed of. You may assume that  1<=n<=100000. Then follow  n integers  h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is  1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

Hint

Huge input, scanf is recommended.


题意:找到一个直方图里最大矩形面积。

思路:暴力搞肯定不行的。我们来看最终的结果肯定是在一段区间的长度乘以这个区间最小矩形的高度。

如果我们已经知道了最小的矩形,怎么求区间长度呢。

假设我们的区间为[s,t],区间最小矩形的高度是h[i],那么h[s-1]和h[t+1]都要小于h[i]才行(都说了是最小矩形了嘛)

因为只需要对端点值进行操作,用栈可以高效求解

以求左端点为例,在求解对于点i来说的s的时候,取出栈顶元素的值,如果其对应矩形的高度大于h[i],那么肯定包括在端点里头。直到小于h[i]或者栈为空为止。记录左端点。右端点同理。


#include <cmath>
#include <cstring>
#include <cstdio>
#include <vector>
#include <string>
#include <algorithm>
#include <string>
#include <map>
#include <queue>
#include <set>
#include <stack>
using namespace std;
#define MAXN 100010
#define LEN 200010
#define INF 1e9+7
#define MODE 1000000
#define pi acos(-1)
#define g 9.8
typedef long long ll;

int n;
int h[MAXN];
int l[MAXN],r[MAXN];
stack <int> ans;



int main()
{
    while(scanf("%d",&n)!=INF)
    {
        if(n==0)
            break;
        for(int i=0;i<n;i++)
            scanf("%d",h+i);
        while(!ans.empty())
            ans.pop();
        ans.push(0);
        l[0]=0;
        for(int i=1;i<n;i++)
        {
            while(!ans.empty()&&h[ans.top()]>=h[i])
            {
                ans.pop();
            }
            if(ans.empty())
                l[i]=0;
            else
                l[i]=ans.top()+1;
            ans.push(i);
        }
        while(!ans.empty())
            ans.pop();
        for(int i=n-1;i>=0;i--)
        {
            while(!ans.empty()&&h[ans.top()]>h[i])
            {
                ans.pop();
            }
            if(ans.empty())
                r[i]=n-1;
            else
                r[i]=ans.top()-1;
            ans.push(i);
        }
        long long res=0;
        for(int i=0;i<n;i++)
            res=max(res,(long long )h[i]*(r[i]-l[i]+1));
        printf("%I64d\n",res);
    }
}










  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值