hdu 1875 继续畅通工程

相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
Sample Input
2
2
10 10
20 20
3
1 1
2 2
1000 1000
Sample Output
1414.2
oh!

最小生成树,把边进队,进行并查集

#include <bits/stdc++.h>
using namespace std;
#define fi first
#define se second
#define ff(i,a,b) for(int i = a; i <= b; i++)
#define f(i,a,b) for(int i = a; i < b; i++)
typedef pair<int,int> P;
#define ll long long
struct node
{
	int x, y;
	double dis;
	bool operator < (const node &rhs) const{
		return dis > rhs.dis;
	}
};

int fa[110];
int find(int x){ return x == fa[x]? x: fa[x] = find(fa[x]);}
P p[110];
priority_queue <node> Q;
double dis(int x1, int y1, int x2, int y2)
{
	return sqrt(1.0 * (x2 - x1) *(x2 - x1) + 1.0 * (y1 - y2) * (y1 - y2));
}


int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin >> t;
    while(t--)
    {
    	int n;
    	cin >> n;
    	ff(i,1,n)
    	{
    		int x, y;
    		cin >> x >> y;
    		p[i] = make_pair(x,y);
    	}
    	ff(i,1,n) fa[i] = i;
    	ff(i,1,n) ff(j,1,n)
    	{
    		double dist = dis(p[i].fi,p[i].se,p[j].fi,p[j].se);
    		Q.push((node){i,j,dist});
    		Q.push((node){j,i,dist});
    	}
    	double tol = 0;
    	int num = 0;
    	while(!Q.empty())
    	{
    		node top = Q.top();
    		Q.pop();
    		if(top.dis < 10.0 || top.dis > 1000.0) continue;
    		int xx = find(top.x);
    		int yy = find(top.y);
    		if(xx == yy) continue;
    		fa[yy] = xx;
    		num++;
    		tol += top.dis * 100;
    	}
    	if(num == n - 1) printf("%.1f\n",tol );
    	else puts("oh!");
    }

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值