uvalive 5004 hdu 3709 Balanced Number 左右数字权和相等(数位dp)

balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It’s your job
to calculate the number of balanced numbers in a given range x,yx,y.
Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
Output
For each case, print the number of balanced numbers in the range x,yx,y in a line.
Sample Input
2
0 9
7604 24324
Sample Output
10
897

题意 求一个区间内有多少个平衡数, 平衡数定义 左右两边数位的距离*数值相加 左右相等
4139 4*2+2==9*1.
数位dp 第一天接触。记录每个数位所在的和值就好 每次枚举该数位上所有的数字对总和的贡献,到达最后位如果pre==0 那么加1.

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
ll dp[22][22][2005];
ll digit[22];

ll DFS(int pos,int central,int pre,int limit)
{
    if(pre<0)
        return 0;
    if(pos<0)
        return pre==0;
    if(!limit&&dp[pos][central][pre]!=-1)
        return dp[pos][central][pre];
    ll ans=0;
    int end=limit?digit[pos]:9;
    for(int i=0;i<=end;i++)
        ans+=DFS(pos-1,central,pre+i*(pos-central),limit&&(i==end));
    if(!limit)
        dp[pos][central][pre]=ans;
    return ans;
}


ll Solve(ll n)
{
    if(n<10) return n+1;
    int len=0;
    while(n)
    {
        digit[len++]=n%10;
        n/=10;
    }
    ll ans=0;
    for(int i=0;i<len;i++)
        ans+=DFS(len-1,i,0,1);
    return ans-len+1;
}

int main(){
    ll a,b;
    int t;
    scanf("%d",&t);
    memset(dp,-1,sizeof(dp));
    while(t--)
    {
        scanf("%lld%lld",&a,&b);
        printf("%lld\n",Solve(b)-Solve(a-1) );
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值