Before being an ubiquous communications gadget, a mobile was just a structure made of strings and wires suspending colourfull things. This kind of mobile is usually found hanging over cradles of small babies
The figure illustrates a simple mobile. It is just a wire, suspended by a string, with an object on each side. It can also be seen as a kind of lever with the fulcrum on the point where the string ties the wire. From the lever principle we know that to balance a simple mobile the product of the weight of the objects by their distance to the fulcrum must be equal. That is Wl × Dl = Wr × Dr where Dl is the left distance, Dr is the right distance, Wl is the left weight and Wr is the right weight.
In a more complex mobile the object may be replaced by a sub-mobile, as shown in the next figure. In this case it is not so straightforward to check if the mobile is balanced so we need you to write a program that, given a description of a mobile as input, checks whether the mobile is in equilibrium or not.
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input is composed of several lines, each containing 4 integers separated by a single space. The 4 integers represent the distances of each object to the fulcrum and their weights, in the format: Wl Dl Wr Dr
If Wl or Wr is zero then there is a sub-mobile hanging from that end and the following lines define the the sub-mobile. In this case we compute the weight of the sub-mobile as the sum of weights of all its objects, disregarding the weight of the wires and strings. If both Wl and Wr are zero then the following lines define two sub-mobiles: first the left then the right one.
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
Write ‘YES’ if the mobile is in equilibrium, write ‘NO’ otherwise
Sample Input
1
0 2 0 4
0 3 0 1
1 1 1 1
2 4 4 2
1 6 3 2
Sample Output
YES
题意:t组数据,每组数据有若干小数据 代表天平的左右端 WL(左边端点重量,为0时表示有子树,继续输入子树) DL(左天平臂长) WR(右边端点重量,为0时表示有子树,继续输入子树) DR (右天平臂长)。根据力矩(力 乘 力臂)判断是否是一个平衡的天平。
思路:由于是若干数据,不明确是多少,但数据都合法,那么我们就在输入数据的时候正好可以构建树,当输入数完成后就构建成了一颗完整的树(端点有重量表示那是叶节点)。然后我们可以根据输入的特性,即先根再左再右,如果遇到端点有重量时不再向下扩展,应向上回溯继续输入。在回溯的过程中正好传递此节点以下的重量和,并与另一端的装量和比较,再回溯。
代码如下:
#include<cstdio>
#include<cstring>
int sove(int &w) //w 相当于此分支目前的重量
{
int wl,dl,wr,dr;
scanf("%d%d%d%d",&wl,&dl,&wr,&dr);
int l=1,r=1; //如果到达页的时候最起码是可以比较
if(!wl) //有左子树
l=sove(wl);//把wl的地址传进去,可以在下一次递归的第十二行把重量值计算出来
if(!wr) //有右子树
r=sove(wr); //同理,获得此节点以下的重量和
w=wl+wr; //左右子树重量相加
if(l&&r&&(wl*dl==wr*dr)) //左边,右边子树重量相等,再比较此时它的重量
return 1;
else
return 0;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int x;
int flag=sove(x);//x 相当于此分支目前的重量
if(flag)
printf("YES\n");
else
printf("NO\n");
if(t)
printf("\n");
}
}