hdu 6047 (贪心)

Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences {ai} and {bi } with the same length n, you are to find the next n numbers of {ai}: an+1…a2nan+1…a2n. Just like always, there are some restrictions on an+1…a2nan+1…a2n: for each number aiai, you must choose a number bkbk from {bi}, and it must satisfy aiai≤max{ajaj-j│bk bk ≤ j < i}, and any bkbk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{∑2nn+1ai∑n+12nai} modulo 109109+7 .

Now Steph finds it too hard to solve the problem, please help him.
Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing {ai}. And the third line consists of n integers representing {bi}.
1≤n≤250000, n≤a_i≤1500000, 1≤b_i≤n.
Output
For each test case, print the answer on one line: max{ ∑2nn+1ai ∑n+12nai} modulo 109109+7。
Sample Input
4
8 11 8 5
3 1 4 2
Sample Output
27

Hint
For the first sample:
1. Choose 2 from {bi}, then a_2…a_4 are available for a_5, and you can let a_5=a_2-2=9;
2. Choose 1 from {bi}, then a_1…a_5 are available for a_6, and you can let a_6=a_2-2=9;

给两个长度为n的序列a, b,现要求max(sum(a[n + 1] + … + a[2n])),其中a[i] = max(a[b[k]] … a[i - 1]),其中b[k]为b[1 … n]中的一个,每个a[i]选择的b[k]不能重复

因为b是1到n 那么保存每一个点后面所有的值中最大的即可,另外保存一个a[n+1] 代表的是后面所有的值中的最大值。而且每次与 a[n+i]和 a[b[i]] 比较最大的,并且更新

#include <bits/stdc++.h>
using namespace std;
const int N = 3e5+100;
const int mod = 1e9+7;
typedef long long ll;
int a[N];
int b[N];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);
        ll total=0;

        int maxx=a[n]-n;
        for(int i=n;i>0;i--)
        {
            maxx=max(maxx,a[i]-i);
            a[i]=maxx;
        }

        sort(b+1,b+n+1);
        total+=a[b[1]];
        a[n+1]=a[b[1]]-n-1;

        for(int i=2;i<=n;i++)
        {
            int h=b[i];
            int res=max(a[b[i]],a[n+1]);
            total+=res;
            total%=mod;
            a[n+1]=max(a[n+1],res-n-i);
        }
        printf("%lld\n",total%mod );
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值