hdu5747 贪心

Aaronson
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 498 Accepted Submission(s): 299

Problem Description

Recently, Peter saw the equation x0+2x1+4x2+…+2mxm=n. He wants to find a solution (x0,x1,x2,…,xm) in such a manner that ∑i=0mxi is minimum and every xi (0≤i≤m) is non-negative.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤105), indicating the number of test cases. For each test case:

The first contains two integers n and m (0≤n,m≤109).

Output

For each test case, output the minimum value of ∑i=0mxi.

Sample Input

10
1 2
3 2
5 2
10 2
10 3
10 4
13 5
20 4
11 11
12 3

Sample Output

1
2
2
3
2
2
3
2
3
2
宝宝之间都没A过BestCoder里的题目,感觉自己还是太水了,拿个最简单的再试试,没想到一次就A了。可以的。

题目的意思很明显吧,就不说了,值的一提的是, Xi是非负的整数!

这里看n和m的范围就知道,其实n也就是int的范围内,所以Xi (i>30) 的取值肯定等于0。

可能有的朋友会纠结,那31和32哪去了?int 可是4个字节。

有点常识的都知道int 是补码表示,表示范围是2^31 -1 到 2^31 , 所以2^31-1 >n>0。所以只考虑Xi<=30的时候。

还有一个就是题目要求SumXi 值最小,不难想到用贪心就能很好得解决了。从后向前贪。

好的, 上代码,就几行:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int n,m;
int main(){
    int t;
    //freopen("hdu5747.in", "rw", stdin);
    cin>>t;
    while(t--){
        scanf("%d%d", &n, &m);
        int ans=0;
        int ran=min(30, m);
        for(int i=ran;i>=0;i--){
            int tmp;
            tmp=pow(2, i);
            if(tmp>n)continue;
            ans+=n/tmp;
            n%=tmp;
        }
        printf("%d\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值