YT14-HDU-求斐波那契数列

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

代码如下:

#include <iostream>
using namespace std;
int num[10000];
int main()
{
    int A,B,n;
    num[1] = num[2] = 1;
    while(cin>>A>>B>>n, A !=0|| B!=0 || n!=0)
    {
        int i;
        for(i=3; i<10000 ; i++)
        {
            num[i] = (A*num[i-1] + B*num[i-2]) % 7;
            if(num[i] == 1 &&num[i-1] == 1)
                break;
        }
        n = n % (i-2);
        num[0] = num[i-2];
        cout << num[n] << endl;
    }
    return 0;
}

运行结果:



代码是借鉴网上的,自己写的全都是RUNTIME ERROR。心塞,连斐波那契都不会了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值