YT14-HDU-机器人走表格

Problem Description



A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page)
S south (down the page)
E east (to the right on the page)
W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

代码如下:

#include <iostream>
using namespace std;
char str1[11][11];                  //将表格用字符型二维数组表示
int main()
{
    int a,b,c,i,j;
    int k,p,q=0;
    while(cin>>a>>b>>c)           //输入表格的长度a、宽度b和机器人进入表格的位置c
    {
        int num[11][11]={1};      //用一个二维数组记录 
        k=0;                      //k代表总步数
        p=1;                      //机器人一定是由第一行进入的
        if (a==0||b==0)
            break;
        for (i=1; i<=a; i++)
        {
            for (j=1; j<=b; j++)
            {
                cin>>str1[i][j];               //输入表格中各字符。
            }
        }
        q=c;                                   //机器人进入的初始位置(p,q)=(1,c)                                 
        int str2[11][11];         
        for (i=1; i<=a; i++)
            for (j=1; j<=b; j++)
                str2[i][j]=0;                  //将图用另外一组二维数组表示,初始都为0
        str2[p][q]=1;                          //机器人进入的那个位置更改为1;
        do
        {
            if (str1[p][q]=='W')                //如果表格当前区域的字符是W,则向
                q--;
            else if (str1[p][q]=='S')
                p++;
            else if (str1[p][q]=='N')
                p--;
            else if (str1[p][q]=='E')
                q++;
            if (str2[p][q]==1&&p>0&&q>0&&p<=a&&q<=b) //如果这一位置已经走过且在表格内
            {
                cout<<num[p][q]<<" step(s) before a loop of "<<k-num[p][q]+1<<" step(s)"<<endl;
                break;                              //输出第一次进入循环和这一循环内的步数 
            }
            k++;                                   //总步数+1;
            num[p][q]=k;                           //记录第一次走到这一位置的步数。
            if (p<=0||q<=0||p>a||q>b)              //如果不在表格内,说明走出了表格
            {
                cout<<k<<" step(s) to exit"<<endl;
                break;
            }
            str2[p][q]=1;                         //将走过的位置更改为1;
        }
        while(1);
    }
    return 0;
}


代码思路:

首先题目的大概意思是一个机器人从表格的第一行的某一位置进入表格,按照表格中各位置的字符移动,如果走出了表格,则输出多少步走出去,如果走不出去,说明陷入了循环,输出第一次进入循环时走了多少步和这一循环内的步数。

用数组str1表示字符,str2来表示是否走过这一位置,在这道题中,如果能走出去,直接统计步数输出就行,当如果走到一个走过的位置,就肯定会陷入循环走不出去的,所以当下一步的位置代表的数字为1时,说明陷入了循环,这时利用此时的步数减去第一次到达下一步的位置的步数+1就行。(用num数组记录了到达每一个位置的步数。)



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值