POJ-2378-Tree Cutting(树形DP)

Tree Cutting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5714 Accepted: 3477

Description

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses. 

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ. 

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

* Line 1: A single integer, N. The barns are numbered 1..N. 

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

题意:一棵树让你删除一个点,分成两个部分,剩下两部分的点数均满足<=n/2(实际上就是两堆中最大的那堆小于就好了),让你从小到大输出所有满足这种情况的点数

题意分析:这题是个树形DP,代码看上去是个dfs实际上是个dp,dp[i]=max(k,n-num[i])表示删除这个节点的情况下,最大的子节点联通块中的点个数与不是这个点的子节点的那一堆连通块中点的个数

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<algorithm>
#define N 10005
using namespace std;
int n,x,y;
int num[N],f[N];//num用来储存节点i的总子节点个数,f用来储存删除节点i时的所有的父节点,子节点最大堆的节点个数
vector<int>v[N];
bool flag;
void dfs(int x,int fa)
{
	num[x]=1;//自己本身算一个节点
	int k=0;//k用来储存所有的子节点中最大的堆
	for(int i=0;i<v[x].size();i++)
	{
		int nex=v[x][i];
		if(nex==fa)continue;
		dfs(nex,x);
		k=max(k,num[nex]);//求所有子节点中最大的那一堆子节点个数
		num[x]+=num[nex];//表示自己+子节点个数
	}
	f[x]=max(k,n-num[x]);//n-num[x]实际上就是指除了自己跟子节点剩下的父节点那一堆的数量
	//因为对于当前的x节点,我所能找到的也就只能是x节点下面的点,对于父节点那一堆因为x被删剩下的点数量=总结点数-[当前节点(1)+当前节点的子节点]
	//这个dp的特点是,删除之前的点的答案跟删除当前点的答案没有影响,只有之前点的子节点个数对当前节点的子节点个数有影响
}
int main()
{
	while(~scanf("%d",&n))
	{
		flag=0;
		memset(num,0,sizeof(num));
		memset(f,0,sizeof(f));
		for(int i=1;i<=n;i++)v[i].clear();
		for(int i=1;i<n;i++)
		{
			scanf("%d%d",&x,&y);
			v[x].push_back(y);
			v[y].push_back(x);
		}
		dfs(1,-1);
		for(int i=1;i<=n;i++)
			if(f[i]<=n/2)
			{
				flag=1;
				printf("%d\n",i);
			}
		if(!flag)printf("NONE\n");
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值