poj 2378 Tree Cutting 树形DP

Tree CuttingTime Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.

Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.

Please help Bessie determine all of the barns that would be suitable to disconnect.

Input

* Line 1: A single integer, N. The barns are numbered 1..N.

* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.

Output

* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".

Sample Input

10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8

Sample Output

3
8

Hint

INPUT DETAILS:

The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles.

OUTPUT DETAILS:

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

题意:给出一个节点树为n的树,要求找出一些节点,当删去这个节点以及它所连接的边后,剩下的每一个部分的节点树都不大于n/2,从小到大输出满足条件的节点。


思路:很容易想到,当删除一个节点p后,会出现:

1.除了以p节点为根的子树的部分,这部分的节点数为n-(以p节点为根的子树的节点树)

2.以p节点的每一个孩子为根的子树

如果这些部分全都满足节点数不大于n,那么p节点自然是满足条件的


我们首先需要建树,我采用vector方法,保证不超内存,用邻接表也可以,然后dfs遍历这棵树,计算以每一个节点为根的子树中节点的数量,并判断,将满足条件的节点做标记,最后按顺序输出即可

#include <iostream>
#include <stdio.h>
#include <vector>
#include <string.h>
using namespace std;



vector<int> p[10010];
int nodenum[10010];
bool vis[10010];
bool res[10010];
int n,half;
void init()
{
    memset(vis,false,sizeof(vis));
    memset(res,false,sizeof(vis));
}

int dfs(int x)
{
    bool ok=true;
    nodenum[x]=1;
    int num=p[x].size();
    int i;

    for(i=0;i<num;i++)
    {
        if(!vis[p[x][i]])
        {
            vis[x]=true;
            int tmp=dfs(p[x][i]);
            if(tmp>half)
                ok=false;
            nodenum[x]+=tmp;
        }
    }
    if(ok&&n-nodenum[x]<=half)
        res[x]=true;
    return nodenum[x];
}


int main()
{
    int u,v,i;
    while(~scanf("%d",&n))
    {
        init();
        half=n/2;
        for(i=0;i<n-1;i++)
        {
            scanf("%d%d",&u,&v);
            p[u].push_back(v);
            p[v].push_back(u);
        }
        vis[1]=true;
        dfs(1);
        for(i=1;i<=n;i++)
        {
            if(res[i])
                printf("%d\n",i);

        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值