【C++】「一本通 1.2 例 1」愤怒的牛(Aggressive cows)

【来源】

USACO 2005 Feb. Gold
一本通题库-1433
BZOJ-1734
LibreOJ-10011
POJ-2456
OpenJ_Bailian-2456
SCU-2755
SPOJ
vjudge

注:SPOJ的输入格式与其他题库不同。

【题目描述】

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

农夫 John 建造了一座很长的畜栏,它包括N (2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,…,xN (0 <= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢

【输入格式】

  • Line 1: Two space-separated integers: N and C
  • Lines 2…N+1: Line i+1 contains an integer stall location, xi
  • 第一行:空格分隔的两个整数N和C
  • 第二行:第N+1行:i+1行指出了xi的位置

【输出格式】

  • Line 1: One integer: the largest minimum distance
  • 第一行:一个整数,最大的最小值

【样例输入】

5 3
1
2
8
4
9

【样例输出】

3

【样例说明】

把牛放在1,4,8这样最小距离是3

【数据范围】

2 ≤ n ≤ 1 0 5 2 \leq n \leq 10^5 2n105, 0 ≤ x i ≤ 1 0 9 0 \le x_i \le 10^9 0xi109, 2 ≤ m ≤ n 2 \le m \le n 2mn

【解析】

二分最小距离。

【代码】

#pragma GCC optimize(3,"Ofast","inline")
#pragma G++ optimize(3,"Ofast","inline")

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>

#define RI                 register int
#define re(i,a,b)          for(RI i=a; i<=b; i++)
#define ms(i,a)            memset(a,i,sizeof(a))
#define MAX(a,b)           (((a)>(b)) ? (a):(b))
#define MIN(a,b)           (((a)<(b)) ? (a):(b))

using namespace std;

typedef long long LL;

const int N=1e5+5;

int n,m;
int a[N];

int main() {
    scanf("%d%d",&n,&m);
    for(int i=1; i<=n; i++) scanf("%d",&a[i]);
    sort(a+1,a+n+1);
    int l=1,r=a[n]-a[1];
    while(l<r) {
        int mid=(l+r+1)>>1,cnt=1,k=a[1];
        for(int i=2; i<=n; i++) 
            if(a[i]-k>=mid) cnt++,k=a[i];
        if(cnt>=m) l=mid;
            else r=mid-1;
    }
    printf("%d\n",l);
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值