Aggressive cows 愤怒的牛(c++)

题目描述

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

农夫 John 建造了一座很长的畜栏,它包括NN (2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,...,xN (0 <= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢

输入格式

* Line 1: Two space-separated integers: N and C * Lines 2..N+1: Line i+1 contains an integer stall location, xi

第一行:空格分隔的两个整数N和C

第二行---第N+1行:i+1行指出了xi的位置

输出格式

* Line 1: One integer: the largest minimum distance

第一行:一个整数,最大的最小值

样例

样例输入

5 3
1
2
8
4
9

样例输出

3

数据范围与提示

把牛放在1,4,8这样最小距离是3 

代码

#include<bits/stdc++.h>
using namespace std;
int n,m,a[100005]; 
int main(){
	cin>>n>>m;
	for(int i=1;i<=n;i++) scanf("%d", &a[i]);
	sort(a+1,a+1+n);
	int left=1,right=a[n],mid,ans=0;
	while(left<=right){
		mid=(left+right)/2;
		int now=1,s=1;
		for(int i=2;i<=n;i++){
			if(a[i]-a[now]>=mid){
				s++;
				now=i;
			}
		}
		if(s>=m){
			ans=mid;
			left=mid+1;
		}
		else right=mid-1;
	}
	cout<<ans;
	return 0;
}

  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值