关于scikit-learn与其他包的兼容问题

郁闷了一天终于解决了scikit-learn与其他包的兼容问题。

我安装的软件版本python2.7,scikit-learn-0.16.1,numpy-1.8.1,scipy-0.15.1

当导入sklearn.datasets时出错,

原来是与numpy版本不兼容问题,开始我安装的是numpy-1.6.1,后来改成numpy-1.8.1问题就解决了!

 

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页