扫描线——求矩形混合面积——poj 1151 Atlantis

扫描线——解决有关多个矩形重叠的问题
扫描线可以有四个方向 思想都是一样的 只是预处理的时候要根据选择的处理
以自下至上为例
每一个矩形 储存其上下两条边 记录边的高度(y) 左右端点(x)和是矩形的上边还是下边 同时开一个数组把所有的端点的横坐标记录下来 我们的线段树中维护的就是这些横坐标在这个数组中的下标(因为坐标可能是小数所以没有办法直接维护)
根据高度从小到大将边和横坐标数组排序 然后遍历总数-1条边 根据需要不断维护线段树

原题链接:poj 1151 Atlantis

Atlantis

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 23429Accepted: 8717

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.
The input file is terminated by a line containing a single 0. Don’t process it.

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.
Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 





#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#define max_ 110
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;
struct node
{
    int l,r,s;
    double len;
};
struct edge
{
    double l,r,h;
    int f;
};
struct node tree[max_*8];
struct edge e[max_*2];
int n,casenum=1;
double x[max_*2];
bool cmp(const edge &a ,const edge &b)
{
    return a.h<b.h;
}
void build(int i,int l,int r)
{
    tree[i].l=l;
    tree[i].r=r;
    tree[i].s=0;
    tree[i].len=0;
    if(l==r)
        return;
    int mid=(l+r)>>1;
    build(i<<1,l,mid);
    build(i<<1|1,mid+1,r);
}
void pushdown(int i)
{
    if(tree[i].s)
        tree[i].len=x[tree[i].r]-x[tree[i].l-1];
    else if(tree[i].l==tree[i].r)
        tree[i].len=0;
    else
        tree[i].len=tree[i<<1].len+tree[i<<1|1].len;
}
void update(int i,int l,int r,int v)
{
    if(tree[i].l==l&&tree[i].r==r)
    {
        tree[i].s+=v;
        pushdown(i);
        return;
    }
    int mid=(tree[i].l+tree[i].r)>>1;
    if(r<=mid)
        update(i<<1,l,r,v);
    else if(l>mid)
        update(i<<1|1,l,r,v);
    else
    {
        update(i<<1,l,mid,v);
        update(i<<1|1,mid+1,r,v);
    }
    pushdown(i);
}
int main(int argc, char const *argv[])
{
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(x,0,sizeof(x));
        memset(tree,0,sizeof(tree));
        memset(x,0,sizeof(x));
        int i,cnt=1;
        double ans=0;
        for(i=0;i<n;i++)
        {
            double x1,x2,y1,y2;
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            e[cnt].l=e[cnt+1].l=x1;
            e[cnt].r=e[cnt+1].r=x2;
            e[cnt].h=y1;e[cnt+1].h=y2;
            e[cnt].f=1;e[cnt+1].f=-1;
            x[cnt]=x1;x[cnt+1]=x2;
            cnt+=2;
        }
        build(1,1,cnt-1);
        sort(e+1,e+cnt,cmp);
        sort(x+1,x+cnt);
        for(i=1;i<cnt-1;i++)
        {
            int l=lower_bound(x+1,x+cnt,e[i].l)-x;
            int r=lower_bound(x+1,x+cnt,e[i].r)-x;
            update(1,l+1,r,e[i].f);
            ans+=tree[1].len*(e[i+1].h-e[i].h);
        }
        printf("Test case #%d\n",casenum++);
        printf("Total explored area: %.2f\n\n",ans);
    }

    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值