HDU - 1698 Just a Hook —— 区间更新 区间查询

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35460    Accepted Submission(s): 17322


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.


题意:有一个线段 被分成等长的n段 每一段最开始都是铜的 每次可以把某个区间里的材质改成银的或者金的 最后问整个线段的总价值


思路:线段树的区间更新 在树节点中设置一个lazy标签 表示这个区间被更新过 同时改变记录区间价值的值 每次遇到lazy标签就把它向下更新


#include <iostream>
#include <cstdio>
#include <cstring>
#define max_ 100010
using namespace std;
struct node
{
	int l,r,tag,sum,lazy;
};
struct node tree[max_*4];
int n,q;
void built(int i,int l,int r)
{
	tree[i].l=l;
	tree[i].r=r;
	tree[i].lazy=0;
	tree[i].tag=1;
	if(l==r)
	{
		tree[i].sum=1;
		return;
	}
	int mid=(l+r)>>1;
	built(i<<1,l,mid);
	built(i<<1|1,mid+1,r);
	tree[i].sum=tree[i<<1].sum+tree[i<<1|1].sum;
}
void change(int i,int l,int r,int v)
{
	if(tree[i].l==l&&tree[i].r==r)
	{
		tree[i].lazy=1;
		tree[i].tag=v;
		tree[i].sum=v*(r-l+1);
		return;
	}
	int mid=(tree[i].l+tree[i].r)>>1;
	if(tree[i].lazy)
	{
		tree[i].lazy=0;
		change(i<<1,tree[i].l,mid,tree[i].tag);
		change(i<<1|1,mid+1,tree[i].r,tree[i].tag);
		tree[i].tag=0;
	}
	if(l>mid)
		change(i<<1|1,l,r,v);
	else if(r<=mid)
		change(i<<1,l,r,v);
	else
	{
		change(i<<1,l,mid,v);
		change(i<<1|1,mid+1,r,v);
	}
	tree[i].sum=tree[i<<1].sum+tree[i<<1|1].sum;
}
int main(int argc, char const *argv[])
{
	int r,t;
	scanf("%d",&t);
	for(r=1;r<=t;r++)
	{

		scanf("%d%d",&n,&q);
		built(1,1,n);
		while(q--)
		{
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			change(1,a,b,c);
		}
		printf("Case %d: The total value of the hook is %d.\n",r,tree[1].sum);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值