ZOJ - 1610 Count the Colors —— 区间更新 点查询

Count the Colors

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1


题意:每次操作给定一个区间 将区间中的颜色涂为k


思路:用线段树维护每一个区间的颜色 区间最大为8000 查询时记录下上一个数的颜色 不一样就更新


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int max_=8003;
int tree[max_*4],num[max_],n,last;
void pushdown(int rt)
{
    if(tree[rt]!=-1)
        tree[rt<<1]=tree[rt<<1|1]=tree[rt];
    tree[rt]=-1;
}
void updata(int ql,int qr,int c,int l,int r,int rt)
{
    if(ql<=l&&qr>=r)
    {
        tree[rt]=c;
        return;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    if(ql<=m) 
    	updata(ql,qr,c,l,m,rt<<1);
    if(qr>m) 
    	updata(ql,qr,c,m+1,r,rt<<1|1);
}
void query(int l,int r,int rt)
{
    if(l==r){
        if(tree[rt]!=-1&&tree[rt]!=last)
            num[tree[rt]]++;
        last=tree[rt];
        return;
    }
    pushdown(rt);
    int m=(l+r)>>1;
    query(l,m,rt<<1);
    query(m+1,r,rt<<1|1);
}
int main()
{
    while(scanf("%d",&n)==1)
    {
        memset(tree,-1,sizeof(tree));
        memset(num,0,sizeof(num));
        int a,b,c;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(a<b) 
            	updata(a+1,b,c,1,8000,1);
        }
        last=-1;
        query(1,8000,1);
        for(int i=0;i<=8000;i++)
        {
            if(num[i]) 
            	printf("%d %d\n",i,num[i]);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值