POJ - 2785 4 Values whose Sum is 0 —— 二分

4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 24643 Accepted: 7441
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).


题意:给出四个序列,依次从中取一个数,问有多少种取法使得四个数的和为0。


思路:和取三个数的方式差不多,只要预处理其中任意两个序列就变成取三个数的问题,On2遍历其中两个序列,得出要找的数二分找最后的数。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
#include <cstring>
#include <cmath>
#include <stack>
#define ll long long
using namespace std;

vector<ll>v[5];
int n;
int main()
{
	scanf("%d",&n);
	int i,j;
	ll cnt=0;
	for(i=1;i<=n;i++)
	{
		ll a,b,c,d;
		scanf("%lld%lld%lld%lld",&a,&b,&c,&d);
		v[0].push_back(a);
		v[1].push_back(b);
		v[2].push_back(c);
		v[3].push_back(d);
	}
	for(i=0;i<n;i++)
	{
		for(j=0;j<n;j++)
		{
			v[4].push_back(v[2][i]+v[3][j]);
		}
	}
	sort(v[4].begin(),v[4].end());
	for(i=0;i<n;i++)
	{
		for(j=0;j<n;j++)
		{
			ll k=v[0][i]+v[1][j];
			k=k*-1;
			cnt+=upper_bound(v[4].begin(),v[4].end(),k)-lower_bound(v[4].begin(),v[4].end(),k);
		}
	}
	printf("%lld\n",cnt);
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值