POJ - 3342 Party at Hali-Bula

Party at Hali-Bula
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6714 Accepted: 2369

Description

Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input

The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.

Output

For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.

Sample Input

6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0

Sample Output

4 Yes
1 No


题意:公司要开party,一共有n个人,对于每个人,若他的直接上司去了,他就不能去,若直接上司没去,他可以选择去或者是不去。

问最多可以去多少人,去最多的这种情况是唯一的吗。


思路:树形dp,找x的所有直接下属,若x去,则加上下属不去的最大值,若x不去,则加上下属两种情况的最大值。

找是否只有一种去法时,遍历每个人,若他不去的时候他的下属去或者不去都相等,则为有同种情况。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <cmath>
#include <vector>
#define max_ 210
#define inf 0x3f3f3f3f
#define ll long long
using namespace std;

int n;
map<string,int>tran;
int pre[max_],dp[max_][2];
bool vis[max_];
void dfs(int x)
{
    vis[x]=true;
    for(int i=1;i<=n;i++)
    {
        if(vis[i]==false&&pre[i]==x)
        {
            dfs(i);
            dp[x][0]+=max(dp[i][0],dp[i][1]);
            dp[x][1]+=dp[i][0];
        }
    }
}
int main(int argc, char const *argv[]) {
    while(cin>>n&&n)
    {
        tran.clear();
        memset(dp,0,sizeof(dp));
        memset(vis,false,sizeof(vis));
        memset(pre,0,sizeof(pre));
        string s,l;
        cin>>s;
        tran[s]=1;
        int cnt=1;
        for(int i=1;i<n;i++)
        {
            cin>>s>>l;
            if(tran[s]==0)
            tran[s]=++cnt;
            if(tran[l]==0)
            tran[l]=++cnt;
            pre[tran[s]]=tran[l];
        }
        for(int i=1;i<=n;i++)
        {
            dp[i][1]=1;
        }
        dfs(1);
        int f=0;
        for(int i=1;i<n;i++)
        {
            if(dp[i][0]>dp[i][1])
            {
                for(int j=1;j<=n;j++)
                {
                    if(pre[j]==i)
                    {
                        if(dp[j][0]==dp[j][1])
                        {
                            f=1;
                            break;
                        }
                    }
                }
                if(f)
                break;
            }
        }
        printf("%d",max(dp[1][1],dp[1][0]));
        if(dp[1][1]==dp[1][0]||f)
        {
            printf(" No\n" );
        }
        else
        {
            printf(" Yes\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值