【POJ - 3342】Party at Hali-Bula (树形dp+判断)

Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.

Best,
--Brian Bennett

P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input

The input consists of multiple test cases. Each test case is started with a line containing an integer n (1 ≤ n ≤ 200), the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n-1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0.

Output

For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case.

Sample Input

6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0

Sample Output

4 Yes
1 No

解题报告:

非常明显的一树形dp问题,至于要判断有没有重复,就只需要加点判断。首先如果根节点选和不选的值一样,那么肯定就是有没有唯一解,其次如果中间某个结点的值,由他的子节点的值推出来,而他的子节点已经被标记过了(就是子节点的最优解是有多种方式出来的),因此这个点的选择方式也不说唯一的,而根节点处的最优解又用到了这个结点的值,那么就是没有唯一解。mk数组就是用来记录中间结点的最优解是不是唯一的。

ac代码:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<set>
#include<iostream>
#include<map>
#include<stack>
#include<cmath>
#include<algorithm>
#define ll long long
#define mod 1000000007
#define eps 1e-8
using namespace std;
struct node{
	int u;int v;
	int nex;
}side[22000];
int head[2000];
int dp[2000][2];
int mk[2000][2];
int cnt;
void init()
{
	cnt=0;
	memset(head,-1,sizeof(head));
	memset(dp,0,sizeof(dp)); 
	memset(mk,0,sizeof(mk));
}
void add(int u,int v)
{
	side[cnt].u=u;
	side[cnt].v=v;
	side[cnt].nex=head[u];
	head[u]=cnt++;
}
void dfs(int rt)
{
	for(int i=head[rt];i!=-1;i=side[i].nex)
	{
		int ty=side[i].v;
		dfs(ty);
		if(mk[ty][0]==1)
		{
			mk[rt][1]=1;
		}
		dp[rt][1]+=dp[ty][0];
		
		if(dp[ty][0]==dp[ty][1])
		{
			dp[rt][0]+=dp[ty][0];
			mk[rt][0]=1;
		}
		else if(dp[ty][0]>dp[ty][1])
		{
			dp[rt][0]+=dp[ty][0];
			if(mk[ty][0]==1)
			mk[rt][0]=1;
		}
		else
		{
			dp[rt][0]+=dp[ty][1];
			if(mk[ty][1]==1)
			mk[rt][0]=1;
		}
	}
}
map<string,int> mp;
int main()
{
	int n;
	while(~scanf("%d",&n),n)
	{
		mp.clear();
		init();
		int id=1;
		string s1,s2;
		int u,num,v;
		for(int i=0;i<n+1;i++)
		dp[i][1]=1;
		cin>>s1;
		mp[s1]=1;
		id++;
		for(int i=0;i<n-1;i++)
		{
			cin>>s1>>s2;
			if(!mp[s1])
			{
				mp[s1]=id++;
			}
			if(!mp[s2])
			{
				mp[s2]=id++;
			}
			add(mp[s2],mp[s1]);
		}
		int ans;
		int ff=1;
		dfs(1);
		if(dp[1][0]==dp[1][1])
		{
			ans=dp[1][0];
			ff=0;	
		}
		else if(dp[1][0]>dp[1][1])
		{
			ans=dp[1][0];
			if(mk[1][0])
			ff=0;
		}
		else
		{
			ans=dp[1][1];
			if(mk[1][1])
			ff=0;
		}
		if(ff)
		{
			printf("%d Yes\n",ans);
		}
		else
		{
			printf("%d No\n",ans);
		}		
	} 
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值