HDU - 1358 Period —— next数组求循环节

8 篇文章 0 订阅

Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10311    Accepted Submission(s): 4905


Problem Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.
 

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
 

Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
 

Sample Input
 
 
3 aaa 12 aabaabaabaab 0
 

Sample Output
 
 
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4

题意:给定长度为n的字符串,问循环节每次循环的位置和次数

思路:求出next数组后,遍历每一个位置找当前位置的循环节,看是否正好循环了两次以上

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <stack>
#include <cstring>
#include <queue>
#include <algorithm>
#define ll long long
#define max_ 1010000
#define les 1e-6
#define inf 0x3f3f3f3f
using namespace std;
int f[max_];
char s[max_];
int n,casnum=1;
int main(int argc, char const *argv[]) {
    while(scanf("%d",&n)!=EOF,n)
    {
        scanf(" %s",s);
        f[0]=-1;
        for(int i=1;i<n;i++)
        {
            int j=f[i-1];
            while((j>=0)&&(s[i]!=s[j+1]))
            j=f[j];
            if(s[j+1]==s[i])
            f[i]=j+1;
            else
            f[i]=-1;
        }
        printf("Test case #%d\n",casnum++ );
        for(int i=1;i<n;i++)
        {
            int d=i+1-f[i]-1;
            if((i+1)%d==0)
            {
                if((i+1)/d>=2)
                printf("%d %d\n",i+1,(i+1)/d);
            }
        }
        printf("\n" );
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值