Period HDU - 1358(KMP求next数组)

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input
The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
思路:这道题给定一个字符串,判断这个字符串任一前缀是不是周期的字符串,如果是输出这个字符串的长度和周期 并且长度从小到大输出,通过KMP算法求出next数组这个题就解决了 code:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int Next[1010000];
char a[1010000];
void getNext(){
    int i = -1,j = 0;//两个下标错开
    Next[0] = -1;//第一个初始化为-1
    int lena = strlen(a);//求出字符串长度
    while(j < lena){
        if(i==-1||a[i]==a[j]){
            i++,j++;
            //if(a[i]==a[j])Next[j] = Next[i];//优化
            Next[j] = i;//注意注意!!因为这里是单纯的找前缀中最长的前后缀相同长度,所以不能进行优化,优化长度就改变了
        }
        else i = Next[i];
    }
}
int main(){
    int n;
    int i,j;
    int num = 0;
    while(~scanf("%d",&n)&&n){
        scanf("%s",a);
        getNext();
        printf("Test case #%d\n",++num);
        for(i = 1; i <= n; i++){
            int temp = i-Next[i];//这句话求循环节的长度,仔细想想你会发现,如果不循环,那么i-Next[i]的值肯定大于前缀总长度的一般,而如果循环肯定小于等于一半
            if(i%temp==0&&i/temp>1){//能整除说明是周期字符串,并且题目要求周期大于1
                printf("%d %d\n",i,i/temp);
            }
        }
        printf("\n");
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值