POJ - 3276 Face The Right Way —— 开关

Face The Right Way
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6191 Accepted: 2866

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer:  N 
Lines 2.. N+1: Line  i+1 contains a single character,  F or  B, indicating whether cow  i is facing forward or backward.

Output

Line 1: Two space-separated integers:  K and  M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

题意:有n头牛排成一列,每头牛朝前或者朝后,有一个操作可以使连续的k头牛转向,问使得全部牛都转向前方的最少操作次数和此时的k

思路:一维的反转问题,暴力遍历每个k,判断是否能使得全部牛转向前方

判断时,每遇到一个反向的牛就使其转向

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <cmath>
#include <vector>
#define max_ 5010
#define inf 0x3f3f3f3f
#define ll long long
#define les 1e-13
using namespace std;
int n;
int num[max_];
int f[max_];
int main()
{
	scanf("%d", &n);
	for (int i = 1;i <= n;i++)
	{
		char c;
		scanf(" %c", &c);
		if (c == 'B')
		{
			num[i] = 1;
		}
		else
		{
			num[i] = 0;
		}
	}
	int K=n, M = n;
	for (int k = 1;k <= n;k++)
	{
		int sum = 0,cnt=0;
                memset(f,0,sizeof f);
		for (int i = 1;i + k - 1 <= n;i++)
		{
			if ((sum + num[i]) & 1)
			{
				f[i] = 1;
				sum++;
				cnt++;
			}
			if (i - k +1 >= 1)
				sum -= f[i - k+1 ];
		}
		int flag = 1;
		for (int i = n - k + 2;i <= n;i++)
		{
			if ((sum + num[i]) & 1)
			{
				flag = 0;
				break;
			}
			if (i - k +1>= 1)
				sum -= f[i - k+1];
		}
		if (flag)
		{
			if (M > cnt)
			{
				M = cnt;
				K = k;
			}
		}
	}
	printf("%d %d\n", K, M);
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值