POJ 1001Exponentiation(高精度浮点乘法)

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.
Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.
Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don’t print the decimal point if the result is an integer.
Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12
Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201
Hint

If you don’t know how to determine wheather encounted the end of input:
s is a string and n is an integer
C++

while(cin>>s>>n)

{

}

c

while(scanf(“%s%d”,s,&n)==2) //to see if the scanf read in as many items as you want

/while(scanf(%s%d”,s,&n)!=EOF) //this also work /

{

}
Source

East Central North America 1988

题目大意:
每次给定两个 R ,N 求R ^ N ( R 为0-99.999内的一个实数,含小数点共六位 N为0-25内的整数)

题解:
1、先忽略小数点进行高精度计算
2、对于前导零 标记小数点前出现的第一个非零数和该数前面的所有零
3、对于后导零 倒着for一遍处理方法如前导零
4、小数点的输出注意如果小数点后为零且为后导零中的一个 就不输出小数点
5、进行n-1遍高精乘 注意清空数组

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 2333;
char ss[10];
int n,pos,len,lena,lenb,r,cnt,sum;
int c[maxn], a[maxn], b[maxn],d[maxn];
bool vis[maxn];
void work()
{
    memset(c, 0, sizeof(c));
    for (int i = 1; i <= lena; i++)
    {
        for (int j = 1; j <= lenb; j++)
        {
            c[i+j-1] += a[i] * b[j];
            if (c[i+j-1] >= 10) 
            {
                c[i+j] += c[i+j-1] / 10;
                c[i+j-1] %= 10;
            }
        }
    }
    lena += lenb;
    for (int i = 1; i <= lena; i++) 
        a[i] = c[i];
}

int main()
{
    while (cin >> ss >> n)
    {
        memset(vis,0,sizeof(vis));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(d,0,sizeof(d));
        int tot = 1;
        pos = -1,r = 0,len = 1,cnt = 0;
        for (int i = 5;i >= 0; i --)
        {
            if (ss[i] != '.') 
                a[tot] = b[tot++] = ss[i] - '0';
            else pos = i;
        }
        if (pos == -1) lena = lenb = 6;
        else
        {
            lena = lenb = 5;
            pos *= n;
        } 
        for (int i = 1; i < n; i ++)
            work();
        for(int i = lena;i >= 1;i --)
        {
            d[len] = a[i];
            len ++;
        }
        for(int i = 1;i <= pos;i ++) 
        {
            if(d[i] > 0) break;
            if(d[i] == 0) vis[i] = 1;
        }

        for(int i = len - 1;i > 0;i --)
        {
            if(d[i] != 0 || i == pos) break;
            if(d[i] == 0) vis[i] = 1;
        }
        for(int i = 1;i < len;i ++)
        {
            if(i == pos + 1 && !vis[pos+1]) cout << '.' ;
            if(vis[i]) continue;
            else cout << d[i];
        }
        cout << endl;
    }
    return 0;
}

/*

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值