【bzoj2763】【JLOI2011】飞行路线

也就我这种蒟蒻才会写这种裸分层图的题解吧……

Description

Alice和Bob现在要乘飞机旅行,他们选择了一家相对便宜的航空公司。该航空公司一共在n个城市设有业务,设这些城市分别标记为0到n-1,一共有m种航线,每种航线连接两个城市,并且航线有一定的价格。Alice和Bob现在要从一个城市沿着航线到达另一个城市,途中可以进行转机。航空公司对他们这次旅行也推出优惠,他们可以免费在最多k种航线上搭乘飞机。那么Alice和Bob这次出行最少花费多少?

Input

数据的第一行有三个整数,n,m,k,分别表示城市数,航线数和免费乘坐次数。
第二行有两个整数,s,t,分别表示他们出行的起点城市编号和终点城市编号。(0<=s,t<n)
接下来有m行,每行三个整数,a,b,c,表示存在一种航线,能从城市a到达城市b,或从城市b到达城市a,价格为c。(0<=a,b<n,a与b不相等,0<=c<=1000)

Output

只有一行,包含一个整数,为最少花费。

Sample Input

5 6 1
0 4
0 1 5
1 2 5
2 3 5
3 4 5
2 3 3
0 2 100

Sample Output

8

HINT

对于30%的数据,2<=n<=50,1<=m<=300,k=0;
对于50%的数据,2<=n<=600,1<=m<=6000,0<=k<=1;
对于100%的数据,2<=n<=10000,1<=m<=50000,0<=k<=10.

再说一遍,也就我这样的辣鸡蒟蒻写这样的分层图裸题题解了吧……
直接上代码!

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
struct Edge
{
    int to,dist,next;
}edge[100020];
int head[50010],dist[50010][21],tot,now,n/*城市数*/,m/*航班数*/,k/*免费数*/,s/*开始*/,t/*到达*/;
bool passed[50010][21];
void add(int ff,int tt,int dd)
{
    edge[++tot].to=tt;
    edge[tot].dist=dd;
    edge[tot].next=head[ff];
    head[ff]=tot;
}
queue<int> q;
void spfa()
{
    q.push(s);
    q.push(0);
    passed[s][0]=1;
    dist[s][0]=0;
    while(!q.empty())
    {
        int x=q.front();
        q.pop();
        now=q.front();
        q.pop();
        passed[x][now]=0;
        for(int i=head[x];i!=-1;i=edge[i].next)
        {
            Edge e=edge[i];
            if(dist[e.to][now]>dist[x][now]+e.dist)
            {
                dist[e.to][now]=dist[x][now]+e.dist;
                if(!passed[e.to][now])
                {
                    passed[e.to][now]=1;
                    q.push(e.to);
                    q.push(now);
                }
            }
            if(now<k&&dist[e.to][now+1]>dist[x][now])
            {
                dist[e.to][now+1]=dist[x][now];
                if(!passed[e.to][now+1])
                {
                    passed[e.to][now+1]=1;
                    q.push(e.to);
                    q.push(now+1);
                }
            }
        }
    }
    cout<<dist[t][k];
}
int main()
{
    scanf("%d%d%d\n%d%d",&n,&m,&k,&s,&t);
    for(int i=0;i<=10;i++)
        for(int j=0;j<=10005;j++)
            dist[j][i]=0x7ffffff;
    memset(head, -1, sizeof(head));
    for(int i=0;i<m;i++)
    {
        int ff,tt,dd;
        scanf("%d%d%d",&ff,&tt,&dd);
        add(ff,tt,dd);
        add(tt,ff,dd);
    }
    spfa();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值