HDOJ 4722Good Numbers 数位DP

Good Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3861    Accepted Submission(s): 1229


Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
 

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

Sample Input
  
  
2 1 10 1 20
 

Sample Output
  
  
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.



#include <cstdio>
#include <cstring>

typedef long long LL;
const int N = 25;
LL dp[N][N];

void init() {
    dp[0][0] = 1;
    for (int i = 0; i < 10; ++i)
        dp[1][i] = 1;
    for (int i = 2; i < N; ++i) {
        for (int j = 0; j < 10; ++j)
            for (int k = 0; k < 10; ++k)
                dp[i][(j + k) % 10] += dp[i - 1][j];
    }
}

LL solve(LL x) {
    if (x < 0) return 0;
    LL ans = 0;
    int len = 0;
    int bit[N]; 
    while (x > 0) {
        bit[++len] = x % 10;
        x /= 10;
    }
    int tt = 0;
    for (int i = len; i > 0; --i) {
        for (int j = 0; j < bit[i]; ++j)
            tt++;
    }
    int carry = 0;
    for (int i = len; i > 0; --i) {
        for (int j = 0; j < bit[i]; ++j) {
            ans += dp[i - 1][(10 - carry) % 10];
            carry = (carry + 1) % 10;
        }
    }

    if (carry % 10 == 0)
        ++ans;

    return ans;
}

int main() {
    int T;
    int cnt = 0;
    init();
    scanf("%d", &T);
    while (T--) {
        LL a, b;
        scanf("%lld%lld", &a, &b);
        printf("Case #%d: %lld\n", ++cnt, solve(b) - solve(a - 1));
    }

    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值