PAT 1020 月饼(C++实现)

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

代码长度限制

16 KB

时间限制

150 ms

内存限制

64 MB

这题依旧是没说完整,第一库存加起来可能不够需求,第二售价都可能是浮点数或者大于int

#include <iostream>
#include <iomanip>
using namespace std;

struct good
{
    double stock;
    double sell;
    double single;
};

int comp(good, good);
void bubble(good*, int);

int main()
{
    int type = 0;
    cin >> type;
    int need = 0;
    cin >> need;
    good* goods = new good[type];
    int i = 0;
    for (i = 0; i < type; i++)
    {
        cin >> goods[i].stock;
    }
    for (i = 0; i < type; i++)
    {
        cin >> goods[i].sell;
        goods[i].single = goods[i].sell / goods[i].stock;
    }
    bubble(goods, type);
    int priority = 0;  //优先选择的商品
    double income = 0;
    while (need && priority<type)
    {
        if (need >= goods[priority].stock)
        {
            need -= goods[priority].stock;
            income += goods[priority].sell;
            priority++;  //这一件已售完
        }
        else
        {
            income += goods[priority].single * need;
            need = 0;
        }
    }
    cout << setprecision(2)<< std::fixed << income << endl;
    delete[] goods;
    return 0;
}


double comp(good* g1, good* g2)
{
    return g2->single - g1->single;
}

void bubble(good* arr, int n)
{
    int i = 0;
    int j = 0;
    good tmp;
    for (i = 0; i < n - 1; i++)
    {
        for (j = 0; j < n - i - 1; j++)
        {
            if (comp(arr + j, arr + j + 1) > 0)
            {
                tmp = arr[j];
                arr[j] = arr[j + 1];
                arr[j + 1] = tmp;
            }
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值