1038 统计同成绩学生

本题要求读入 N 名学生的成绩,将获得某一给定分数的学生人数输出。

输入格式:
输入在第 1 行给出不超过 10 
5
  的正整数 N,即学生总人数。随后一行给出 N 名学生的百分制整数成绩,中间以空格分隔。最后一行给出要查询的分数个数 K(不超过 N 的正整数),随后是 K 个分数,中间以空格分隔。

输出格式:
在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。

输入样例:
10
60 75 90 55 75 99 82 90 75 50
3 75 90 88
输出样例:
3 2 0
代码长度限制
16 KB
时间限制
250 ms
内存限制
64 MB

解题代码:

import java.util.Scanner;
 
public class Main {
 
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		int[] scores = new int[n];
		for(int i=0;i<n;i++) {
			scores[i] = sc.nextInt();
			
		}
 
		int[] count = new int[sc.nextInt()];
		int[] score = new int[count.length];
 
		for(int j=0;j<score.length;j++) {
			score[j] = sc.nextInt();

			for(int i=0;i<scores.length;i++) {
				if(score[j]==scores[i]) {
					count[j]++;
				}
			}
		}

		for(int i=0;i<count.length;i++) {
			while(i!=0) {
				System.out.print(" ");
				break;
			}
			System.out.print(count[i]);
		}
	}
 
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值