HDU 3555 Bomb (数位DP)

原题地址:传送门    (http://acm.hdu.edu.cn/showproblem.php?pid=3555)


Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 13836    Accepted Submission(s): 4989



Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
 
 
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.



这个是简单的数位DP,比我上一篇写的HDU 2089 不要62还要简单。

计算区间内含有49的数字的个数就好。

解释可以看我的HDU 2089 不要62


下面直接贴代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
using namespace std;

long long int dp[90][13];
int digit[90];

long long int dfs(int pos,int pre,bool limit)
{
    if(pos==-1)
    {
        return 0;
    }
    if(!limit&&dp[pos][pre]!=-1)
    {
        return dp[pos][pre];
    }
    long long int res=0;
    int tmp=limit? digit[pos]:9;
    for(int i=0;i<=tmp;i++)
    {
        if(pre==4&&i==9&&!limit)
        {
            res+=(long long int)pow(10,pos);
        }
        else if(pre==4&&i==9&&limit)
        {
            long long int sum=0;
            for(int i=pos-1;i>=0;i--)
            {
                sum+=digit[i]*(long long int)pow(10,i);
            }
            res+=sum+1;
        }
        else
        {
            res+=dfs(pos-1,i,limit&&i==tmp);
        }
    }
    if(!limit)
    {
        dp[pos][pre]=res;
    }
    return res;
}
long long int cal(long long int a)
{
    int len=0;
    while(a)
    {
        digit[len++]=a%10;
        a=a/10;
    }
    return dfs(len-1,0,1);
}
int main()
{
    long long int t,a;
    scanf("%I64d",&t);
    while(t--)
    {
        memset(dp,-1,sizeof(dp));
        scanf("%I64d",&a);
        printf("%I64d\n",cal(a)-cal(0));
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值