每日三题-Day3-B(HDU 1260 Tickets 基础DP)

原题地址

Tickets

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4031 Accepted Submission(s): 2023


Problem Description
Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input
There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output
For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input
  
  
2 2 20 25 40 1 8

Sample Output
  
  
08:00:40 am 08:00:08 am


题意:

n个人买票,给出每个人单个人买所需的时间,以及相邻两个人买的时间。

求所有人买完票所需的最短时间。


思路:

基础DP

第i个人可以有两种选择,自己单独买和跟自己前一个人一起买。判断时间哪个短。

sine[i]为第i个人单独买票的时间。

to[i]为第i-1个人和第i个人一起买的时间。

设DP[i] 为 1~i个人买票的最短时间,那么DP[i+1] = min( DP[i-1] + sine[i] , DP[i-2] + to[i] );


有个问题是,本来我想用single的缩写sin命名单人数组的。CE了,原来是因为sin是三角函数,会编译错误(前不久省赛选拔,用next命名数组CE一发……)。以后还是要注意命名的二义性啊。




AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int dp[2010];
int to[2010];
int sine[2010];

int main()
{
    int t;
    int n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&sine[i]);
        }
        for(int i=2; i<=n; i++)
        {
            scanf("%d",&to[i]);
        }
        memset(dp,0,sizeof(dp));
        dp[0]=0;
        dp[1]=sine[1];
        for(int i=2; i<=n; i++)
        {
            dp[i]=min(dp[i-1]+sine[i],dp[i-2]+to[i]);
        }
        int ss=dp[n]%60;
        int mm=dp[n]/60;
        int hh=mm/60;
        mm=mm%60;
        int flag=0;
        if(8+hh>=12)
        {
            hh-=12;
            flag=1;
        }
        printf("%02d:%02d:%02d ",8+hh,mm,ss);
        if(flag==1) printf("pm\n");
        else printf("am\n");
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值