USACO 11 OPENCorn Maze S (洛谷P1825)

洛谷查看本题

题面翻译

奶牛们去一个 N × M N\times M N×M 玉米迷宫, 2 ≤ N ≤ 300 , 2 ≤ M ≤ 300 2 \leq N \leq 300,2 \leq M \leq300 2N300,2M300

迷宫里有一些传送装置,可以将奶牛从一点到另一点进行瞬间转移。这些装置可以双向使用。

如果一头奶牛处在这个装置的起点或者终点,这头奶牛就必须使用这个装置,奶牛在传送过后不会立刻进行第二次传送,即不会卡在传送装置的起点和终点之间来回传送。

玉米迷宫除了唯一的一个出口都被玉米包围。

迷宫中的每个元素都由以下项目中的一项组成:

  1. 玉米,# 表示,这些格子是不可以通过的。
  2. 草地,. 表示,可以简单的通过。
  3. 传送装置,每一对大写字母 A \tt{A} A Z \tt{Z} Z 表示。
  4. 出口,= 表示。
  5. 起点, @ 表示

奶牛能在一格草地上可能存在的四个相邻的格子移动,花费 1 1 1 个单位时间。从装置的一个结点到另一个结点不花时间。

题目描述

This past fall, Farmer John took the cows to visit a corn maze. But this wasn’t just any corn maze: it featured several gravity-powered teleporter slides, which cause cows to teleport instantly from one point in the maze to another. The slides work in both directions: a cow can slide from the slide’s start to the end instantly, or from the end to the start. If a cow steps on a space that hosts either end of a slide, she must use the slide.

The outside of the corn maze is entirely corn except for a single exit.

The maze can be represented by an N x M (2 <= N <= 300; 2 <= M <= 300) grid. Each grid element contains one of these items:

* Corn (corn grid elements are impassable)

* Grass (easy to pass through!)

* A slide endpoint (which will transport a cow to the other endpoint)

* The exit

A cow can only move from one space to the next if they are adjacent and neither contains corn. Each grassy space has four potential neighbors to which a cow can travel. It takes 1 unit of time to move from a grassy space to an adjacent space; it takes 0 units of time to move from one slide endpoint to the other.

Corn-filled spaces are denoted with an octothorpe (#). Grassy spaces are denoted with a period (.). Pairs of slide endpoints are denoted with the same uppercase letter (A-Z), and no two different slides have endpoints denoted with the same letter. The exit is denoted with the equals sign (=).

Bessie got lost. She knows where she is on the grid, and marked her current grassy space with the ‘at’ symbol (@). What is the minimum time she needs to move to the exit space?

输入格式

第一行:两个用空格隔开的整数 N N N M M M

2 ∼ N + 1 2\sim N+1 2N+1 行:第 i + 1 i+1 i+1 行描述了迷宫中的第 i i i 行的情况(共有 M M M个字符,每个字符中间没有空格)。

输出格式

一个整数,表示起点到出口所需的最短时间。

样例 #1

样例输入 #1

5 6
###=##
#.W.##
#.####
#.@W##
######

样例输出 #1

3

提示

例如以下矩阵, N = 5 , M = 6 N=5,M=6 N=5,M=6

###=##
#.W.##
#.####
#.@W##
######

唯一的一个装置的结点用大写字母 W \tt{W} W 表示。

最优方案为:先向右走到装置的结点,花费一个单位时间,再到装置的另一个结点上,花费 0 0 0 个单位时间,然后再向右走一个,再向上走一个,到达出口处,总共花费了 3 3 3 个单位时间。

解题思路

本题中共有2种走法,如下:

走法移动距离实现方法
正常1方向数组
传送装置不定判断函数

代码不算太长 , 仅供参考
如果有不对的地方,请指出

AC代码

#include<iostream>//不建议万能头
#include<queue>
using namespace std;
const int N=310;
struct node{
    int x;
    int y;
    int t;
};
queue<node>st;
char a[N][N];
bool vis[N][N];
int n,m;
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};//记录方向
int sx,sy;
void w(int &nx,int &ny,int k){//判断传送装置
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            if(a[i][j]==a[nx][ny]&&(i!=nx||j!=ny)){
                nx=i;
                ny=j;
                return ;
                }
        }
    }
}
void bfs(){
    st.push((node){sx,sy,0});
    while(!st.empty())
    {
        node f=st.front();
        st.pop();
        if(a[f.x][f.y]=='=')
        {
            cout<<f.t;
            return;
        }
        if(a[f.x][f.y]>='A'&&a[f.x][f.y]<='Z')
        {
            w(f.x,f.y,f.t);
        }
        for(int i=0;i<4;i++)
        {
            int nx=f.x+dx[i];
            int ny=f.y+dy[i];
            if(nx>=1&&nx<=n&&ny>=1&&ny<=m&&a[nx][ny]!='#'&&!vis[nx][ny])
            {
                vis[nx][ny]=1;
                st.push((node){nx,ny,f.t+1});
            }
        }
    }
}
int main()
{

    cin>>n>>m;
    string s;
    for(int i=1;i<=n;i++)
    {
        cin>>s;
        for(int j=1;j<=m;j++)
        {
            a[i][j]=s[j-1];
            if(a[i][j]=='@')
            {
                sx=i;
                sy=j;
            }
        }
    }
    bfs();
    return 0;//愉快结束
}
  • 34
    点赞
  • 15
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
题目描述 农夫约翰一直在观察他的奶牛们。他注意到,如果在牛群中有太多的牛靠得太近,就会导致不健康的行为和情感问题。 约翰想知道他的牛群是否存在这个问题。他定义这个问题为:在一个固定长度的路段上,如果有两头高度大于等于 $y$ 的奶牛之间的距离小于 $x$,则牛群中就存在一个挤得太近的情况。 约翰有 $N$ 头牛 ($1 \leq N \leq 50,000$),每头牛的高度为 $h_i$ ($1 \leq h_i \leq 1,000,000$)。他想知道是否存在一对牛,使得它们之间的距离小于 $x$,且它们的高度都大于等于 $y$。 输入格式 第一行包含三个整数 $N, L, R$,分别表示牛的数量,路段长度,和问题的最大高度。 接下来 $N$ 行,每行一个整数 $h_i$,表示每头牛的高度。 输出格式 如果存在一对牛,它们之间的距离小于 $x$,且它们的高度都大于等于 $y$,则输出 $1$,否则输出 $0$。 输入样例1 4 6 4 4 4 5 7 输出样例1 1 输入样例2 5 3 3 1 5 5 5 5 输出样例2 0 提示 对于 $30\%$ 的数据,$N \leq 500$。 对于 $100\%$ 的数据,$1 \leq N \leq 50,000$,$1 \leq L \leq 1,000,000$,且 $L \leq R$。 数据范围 时间限制:1.0s,空间限制:256MB 算法1 (暴力枚举) $O(n^2)$ 首先对输入的牛的高度进行排序,之后枚举每头牛,再枚举它后面的每头牛,如果两头牛的高度均大于等于 $y$,且它们之间的距离小于 $x$,则输出 $1$。如果最后仍然没有满足条件的牛,则输出 $0$。 时间复杂度 暴力枚举,时间复杂度为 $O(n^2)$,无法通过此题。 算法2 (滑动窗口) $O(n \log n)$ 为了方便后续操作,我们将所有的牛按照它们的高度从小到大排序。之后,我们维护一个长度为 $L$ 的滑动窗口,它的右端点与左端点之间的距离小于 $x$。我们从左到右扫描每头牛,将它加入滑动窗口的左端点,同时将滑动窗口右移,直到滑动窗口的右端点与左端点之间的距离小于 $x$。 在处理完一头牛之后,我们需要判断滑动窗口中是否存在一对牛,它们的高度均大于等于 $y$,且它们之间的距离小于 $x$。我们可以用双指针来实现这个操作。我们从滑动窗口的左端点开始,向右移动一个指针 $i$,同时向右移动一个指针 $j$,直到 $h_j - h_i \leq x$。在这个过程中,我们需要判断 $h_i$ 和 $h_j$ 是否均大于等于 $y$。如果存在一对牛满足条件,则输出 $1$。如果最后仍然没有满足条件的牛,则输出 $0$。 时间复杂度 因为需要对所有的牛进行排序,所以时间复杂度为 $O(n \log n)$。 C++ 代码 算法3 (暴力优化) $O(n \log n)$ 首先对输入的牛的高度进行排序,之后枚举每头牛。如果当前牛的高度小于 $y$,则跳过这头牛。否则,我们从它的左边和右边各扩展出一个长度为 $x$ 的区间。如果这两个区间内的牛的数量均大于等于 $2$,且这两个区间中任意两头牛的高度均大于等于 $y$,则输出 $1$。 时间复杂度 因为需要对所有的牛进行排序,所以时间复杂度为 $O(n \log n)$。 C++ 代码
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值