2015 Multi-University Training Contest 5 - 1002 MZL's xor

MZL's xor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all ( Ai + Aj )( 1i,jn ) The xor of an array B is defined as B1 xor B2 ...xor Bn
 

Input
  
  
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases. Each test case contains four integers: n , m , z , l A1=0 , Ai=(Ai1m+z) mod l 1m,z,l5105 , n=5105
 

Output
  
  
For every test.print the answer.
 

Sample Input
  
  
2 3 5 5 7 6 8 8 9
 

Sample Output
  
  
14 16

题意:


Ai=(Ai1m+z) mod l  ,A1=0。求出所有任意两个Ai or Aj。1<=i,j<=n。

题解:

当i!=j时,必有两组Ai,Aj,Aj,Ai。他们的和相同,xor得0。0异或任何数为任何数本身。所以所有i!=j都不需要考虑只需求出当i==j时的结果。需要注意的是求出的Ai int可能会放不下。故开Long long 数组。

参考代码:

#include<stdio.h>
#define M 1000001
long long a[M];
int main()
{
	long long  t,n,m,z,l,sum;
	scanf("%lld",&t);
	while(t--)
	{
	    sum=0;
		scanf("%lld%lld%lld%lld",&n,&m,&z,&l);
        a[1]=0;
        for(int i=2;i<=n;i++)
        	a[i]=(a[i-1]*m+z)%l;
        for(int i=2;i<=n;i++)
            sum^=2*a[i];
        printf("%lld\n",sum);
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值