hdu 5120 - Intersection(解题报告)

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1036    Accepted Submission(s): 407


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778
 
题意:
    求两圆环相交的面积。
参考代码:
#include<stdio.h>  
#include<math.h>  
#define PI acos(-1.0)  
double sum(double a1,double b1,double r1,double a2,double b2,double r2) 
{
    double A1,A2,s1,s2,s,d;                  
        d=sqrt((a2-a1)*(a2-a1)+(b2-b1)*(b2-b1));
        if(d>=r1+r2)  
            return 0.000;     
        else if(d<=fabs(r1-r2))
        {    
            if(r1>r2)      
                return PI*r2*r2;  
            else     
                return PI*r1*r1;  
        }  
        else{  
      
            A1=2*acos((d*d+r1*r1-r2*r2)/(2*d*r1)); 
            A2=2*acos((d*d+r2*r2-r1*r1)/(2*d*r2));  
            s1=0.5*r1*r1*sin(A1)+0.5*r2*r2*sin(A2);  
            s2=A1/2*r1*r1+A2/2*r2*r2;  
            s=s2-s1;  
            return s; 
        }  
}  
int main()
{
	int t;
	scanf("%d",&t);
	for(int q=1;q<=t;q++)
	{
		double r1,r2,a1,a2,b1,b2;
		scanf("%lf%lf%lf%lf%lf%lf",&r1,&r2,&a1,&b1,&a2,&b2);
		printf("Case #%d: ",q);
		printf("%.6lf\n",sum(a1,b1,r2,a2,b2,r2)-2*sum(a1,b1,r2,a2,b2,r1)+sum(a1,b1,r1,a2,b2,r1));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值