OJ Ants

1.题目描述

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

中文翻译:

题目描述:

        一队蚂蚁在一根长 l 厘米的水平杆上行走,每只蚂蚁的恒定速度为1厘米/秒。当一只会走路的蚂蚁走到杆子的尽头时,它立刻从杆子上掉了下来。当两只蚂蚁相遇时,它们会转身朝相反的方向走。我们知道蚂蚁在杆子上的原始位置,不幸的是,我们不知道蚂蚁行走的方向。你的任务是计算所有蚂蚁从柱子上掉下来所需的最早和最晚时间。

输入:

        输入的第一行包含一个整数:给出后面的情况数。

        每种情况的数据都以两个整数开始:杆的长度 l(以厘米为单位)和n(即居住在极点上的蚂蚁数量)。

        这两个数字后面跟着n个整数,给出每个蚂蚁在极点上的位置,为从杆子左端测量的距离,没有特定的顺序。所有输入整数都不大于1000000,并且用空格分隔。

输出:

        对于每种输入情况,输出由一个空格分隔的两个数字。第一个数字是所有蚂蚁从杆子坠落的最早时间(如果它们的行走方向选择得当),第二个数字是最晚的时间。

标准输入:

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

标准输出:

4 8
38 207

2.解题思路

  1. 要是能搞懂,蚂蚁碰面转身和直接通过是等价的(蚂蚁没有区别)就很好写了。
  2. 最短时间: 每只蚂蚁都向距离近的一端走,时间即为每只蚂蚁的最短时间,而这些时间中的最大值就是所有蚂蚁都走出去的最短时间。
  3. 最长时间:首先分析两只蚂蚁相遇的情况:两只蚂蚁相遇时,两只蚂蚁转向,走向端点。这个过程其实等价于蚂蚁相遇不转向走向端点。那么蚂蚁其实还是只往一边走走向终点。这时,每只蚂蚁都向距离最远的一端走,时间即为每只蚂蚁都走出去的最长时间,这些时间中最大值就是所有蚂蚁都走出去的最长时间。

3.代码

# encoding=utf-8
import math

sum = int(input())
# a用来存储每一种情况下杆子上蚂蚁的位置
a = []

# 下面的列表分别用于存储每种情况的最大值和最小值
minlist = []
maxlist = []


# fun()函数用于处理每一种情况
def fun(a, L, n):
    MIN = 0
    MAX = 0
    for i in range(n):
        MIN = max(MIN, min(a[i], L - a[i]))
        MAX = max(MAX, max(a[i], L - a[i]))
    minlist.append(MIN)
    maxlist.append(MAX)


# 主程序
for i in range(sum):
    L, n = map(int, input().split())
    # a = list(map(int, input().split()))
    a = [int(x) for x in input().split()]
    fun(a, L, n)
    a.clear()

for i in range(sum):
    print("{} {}".format(minlist[i], maxlist[i]))

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值