Ants

Ants

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
译文:一队蚂蚁在长度为1厘米的水平杆上行走,每只蚂蚁的速度恒定为1厘米/秒。当一只行走的蚂蚁到达杆的一端时,它会立即从上面掉下来。当两只蚂蚁相遇时,它们会转身并开始向相反方向行走。我们知道蚂蚁在杆子上的原始位置,不幸的是,我们不知道蚂蚁行走的方向。你的任务是计算所有蚂蚁从杆上掉下来所需的最早和最晚时间。

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
译文:第一行输入包含一个整数,给出后面的案例数。每种情况的数据都以两个整数开始:杆的长度(cm)和n,杆上的蚂蚁数量。这两个数字之后是n个整数,它们将杆上每只蚂蚁的位置作为从杆的左端测量的距离,没有特别的顺序。所有输入整数都不大于1000000,它们由空格分隔。

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.
译文:对于每种输入情况,输出由单个空格分隔的两个数字。第一个数字是所有蚂蚁从杆上掉下来的最早时间(如果他们的步行方向选择得恰当),第二个数字是最晚可能的时间。

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

C++编写:

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
    ios::sync_with_stdio(false);
    int num;
    cin>>num;
    while(num--)
    {
        int len,n;
        int max1=0,min1=0;
        cin>>len>>n;
        for(int i=0;i<n;i++)
        {
            int pos;
			cin>>pos;
			max1 = max(max1, max(pos, len-pos));
			min1 = max(min1, min(pos, len-pos));
        }
        cout<<min1<<" "<<max1<<endl;
    }
}

此题不关闭流同步的话,就得把cin改成scanf

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值