OJ(1852):Ants

总时间限制: 

1000ms

 

内存限制: 

65536kB

描述

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

输入

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

输出

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

样例输入

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

样例输出

4 8
38 207

来源

Waterloo local 2004.09.19

题目简述:

n只蚂蚁在长度为Lcm的杆子上爬行,蚂蚁爬到杆子的端点处就会掉落,蚂蚁的爬行速度为每秒1cm,两只蚂蚁相遇就会朝反方向走,问所有蚂蚁掉落的最短和最长时间。

解题思路:

虽然题目说蚂蚁相遇时掉头,但是蚂蚁是完全相同的,可以理解成相遇后继续前行。掉落的最短时间  = 朝离自己近的端点走所用的时间,所有蚂蚁都掉落的最短时间 = 所有蚂蚁都朝离自己近的端点走,其中用时最长的那只所用的时间。最长时间一样。

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#define maxn 100000+10

using namespace std;

int L,n;
int x[maxn];
void solve(){
    int minT = 0;
    for(int i = 0;i < n;i++){
        minT = max(minT,min(x[i],L-x[i]));
    }
    int maxT = 0;
    for(int i = 0;i < n;i++){
        maxT = max(maxT,max(x[i],L-x[i]));
    }
    printf("%d %d\n",minT,maxT);
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&L,&n);
        for(int i = 0;i < n;i++){
            scanf("%d",&x[i]);
        }
        solve();
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值