大数对小数取余

Problem Description

As we know, Big Number is always troublesome.But it's really important in our ACM. And today, your task is to write aprogram to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains lessthan 25 lines.

Input

The input contains several testcases. Each test case consists of two positive integers A and B. The length ofA will not exceed 1000, and B will be smaller than 100000. Process to the endof file.

Output

For each test case, you have toouput the result of A mod B.

Sample Input

2 3
12 7
152455856554521 3250

Sample Output

2
5
1521

A*B % C = (A%C * B%C)%C

(A+B)%C = (A%C + B%C)%C

如 532 mod 7 =(500%7+30%7+2%7)%7;

由此可得大数的每一位对小数求余最后结果再对小数求余就是大数对小数求余的结果

#include<stdio.h>
#include<string.h>
int main()
{
	char str[1000];
	int a,i,len,sum;
	while(scanf("%s%d",str,&a)!=EOF)
	{
		sum=0;
		len=strlen(str);
		for(i=0;i<len;i++)
		{
			sum=(sum*10+str[i]-'0')%a;
		}
		printf("%d\n",sum);
	}
	return 0;
} 



  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值