Prime Factors

问题 J: Prime Factors

时间限制: 1 Sec   内存限制: 32 MB
提交: 23   解决: 18
[ 提交][ 状态][ 讨论版]

题目描述

I'll give you a number , please tell me how many different prime factors in this number.

输入

There is multiple test cases , in each test case there is only one line contains a number N(2<=N<=100000). Process to the end of file.

输出

For each test case , output one line contains one number , indicating different prime factor in the number N.

样例输入

12
5
30

样例输出

2
1
3

提示

12 = 2 * 2 * 3

5 = 5

30 = 2 * 3 * 5




#include<stdio.h>
#include<math.h>
int a[100000];
int prime(int n)
{
	int m=sqrt(n),i;
	for(i=2;i<=m;i++)
	{
		if(n%i==0)
			return 0;
	}
	return 1;
}
int main()
{
	int n,i,k=0,b[99999];
	for(i=2;i<=100100;i++)
	{
		if(prime(i))
			a[k++]=i;
	}
	while(scanf("%d",&n)!=EOF)
	{
		int sum=0,l=0;
		for(i=0;n>1;i++)
		{
			while(n%a[i]==0 && n>1)
			{
				b[l++]=a[i];
				//printf("a[i]==%d n==%d\n",a[i],n);
				n/=a[i];
			}
		}
		sum=1;
		for(i=1;i<l;i++)
			if(b[i]!=b[i-1])
				sum++;
		printf("%d\n",sum);
	}
	return 0;	
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值