简单枚举类型——植物与颜色

简单枚举类型——植物与颜色

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

 请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
 

Input

 输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。

Output

 输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
 

Example Input

blue
yellow
purple

Example Output

Bluebells are blue.
Sunflower are yellow.
I don't know about the color purple.
#include<stdio.h>
#include<string.h>
int main()
{
    char a[50];
    while(gets(a)!=NULL)
    {
        if(strcmp(a,"red")==0)
            printf("Rose are red.\n");
        else if(strcmp(a,"orange")==0)
            printf("Poppies are orange.\n");
        else if(strcmp(a,"yellow")==0)
            printf("Sunflower are yellow.\n");
        else if(strcmp(a,"green")==0)
            printf("Grass are green.\n");
        else if(strcmp(a,"blue")==0)
            printf("Bluebells are blue.\n");
        else if(strcmp(a,"violet")==0)
            printf("Violets are violet.\n");
        else
            printf("I don't know about the color %s.\n",a);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值