Girls' research (HDU - 3294)

One day, sailormoon girls are so delighted that they intend to research about palindromic strings. Operation contains two steps: 
First step: girls will write a long string (only contains lower case) on the paper. For example, "abcde", but 'a' inside is not the real 'a', that means if we define the 'b' is the real 'a', then we can infer that 'c' is the real 'b', 'd' is the real 'c' ……, 'a' is the real 'z'. According to this, string "abcde" changes to "bcdef".
Second step: girls will find out the longest palindromic string in the given string, the length of palindromic string must be equal or more than 2.

Input

Input contains multiple cases. 
Each case contains two parts, a character and a string, they are separated by one space, the character representing the real 'a' is and the length of the string will not exceed 200000.All input must be lowercase. 
If the length of string is len, it is marked from 0 to len-1.

Output

Please execute the operation following the two steps. 
If you find one, output the start position and end position of palindromic string in a line, next line output the real palindromic string, or output "No solution!". 
If there are several answers available, please choose the string which first appears.

Sample Input

b babd
a abcd

Sample Output

0 2
aza
No solution!

题意:给一个字符和一个字符串,将所给的字符设置为a,其后面的字符也以此地推,比如给出的是b,那么b就变为a,c就变为b以此类推,问转换之后的字符串的最长回文串的初始位置和结束位置,并输出最长回文串,如果回文串长度是1输出没有。

思路:直接跑一遍Manacher,但是需要记录回文串的中心位置,然后根据中心位置和长度计算左右端点就可以了。

AC代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#define mem(a, b) memset(a, b, sizeof(a))
using namespace std;
const int maxn = 2e5 + 10;
char s[maxn], s_new[maxn*2];
int Index, len, p[maxn*2];
int init()
{
    int j = 0;
    s_new[j++] = '$';
    s_new[j++] = '#';
    for(int i = 0; i < len; i++)
    {
        s_new[j++] = s[i];
        s_new[j++] = '#';
    }
    s_new[j] = '\0';
    return j;
}

int Manacher()
{
    int n = init();
    int mx = 0, id;
    int max_len = -1;
    for(int i = 1; i < n; i++)
    {
        if(i < mx)
        {
            p[i] = min(p[id*2-i], mx-i);
        }
        else
        {
            p[i] = 1;
        }
        while(s_new[i-p[i]] == s_new[i+p[i]]) p[i]++;
        if(p[i]+i > mx)
        {
            mx = p[i]+i;
            id = i;
        }
        if(max_len < p[i]-1)
        {
            max_len = max(max_len, p[i]-1);
            Index = i;
        }
    }
    return max_len;
}

int main()
{
    char c;
    ios::sync_with_stdio(false);
    while(cin >> c)
    {
        mem(p, 0);
        cin >> s;
        len = strlen(s);
        int v = c-'a';
        for(int i = 0; i < len; i++)
        {
            s[i] = (s[i]-'a'-v+26)%26+'a';
        }
        int ans = Manacher();
        if(ans == 1)
        {
            cout << "No solution!" << endl;
        }
        else
        {
            int L = Index-ans+1;
            int R = Index+ans-1;
            int l = L/2-1, r = R/2-1;
            cout << l << " " << r << endl;
            for(int i = L; i <= R; i++)
            {
                if(s_new[i] != '#' && s_new[i] != '$')
                {
                    cout << char(s_new[i]);
                }
            }
            cout << endl;
        }
        mem(s, 0);
        mem(s_new, 0);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值