杭电oj 1071

杭州电子科技大学 online judge 1071

求积分,计算阴影面积
Problem Description
Ignatius bought a land last week, but he didn’t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

Sample Input
2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222
Sample Output
33.33
40.69

Hint
For float may be not accurate enough, please use double instead of float.

Author
Ignatius.L

个人思路
1.计算抛物线( parabola)的参数a,b,c;

y1 = a*x^2 + b*x +c 

2.计算直线的参数k,m;

y2 = k*x + m

3.在区间 [x2,x3] 内,计算定积分

|f1-f2| dx

4.输出固定的小数位数

代码

#include<iostream>
#include<string> 
#include <iomanip>
using namespace std;
int main()
{
  int case_;
  double x1,y1,x2,y2,x3,y3;
  while((cin>>case_) && (case_))
  {
    for(int i=0;i<case_;i++)
    { 
    cin>>x1>>y1;
    cin>>x2>>y2;
    cin>>x3>>y3;
    double k12=0,k13=0,a=0,b=0,c=0,k=0,m=0,all_num=0;
    k12=(y1-y2)/(x1-x2);
    k13=(y1-y3)/(x1-x3);
    a = (k12-k13)/(x2-x3);//平方项系数 
    b = k12 - a*(x1+x2);//一次项系数 
    c = y1-a*x1*x1-b*x1;//常数项 
    k = (y2-y3)/(x2-x3);//斜率 
    m = y2-k*x2;//常数项 
    all_num = a*x3*x3*x3/3+(b/2-k/2)*x3*x3+(c-m)*x3-(a*x2*x2*x2/3+(b/2-k/2)*x2*x2+(c-m)*x2);
    if(all_num>0) cout<< fixed << setprecision(2) << all_num  << endl;
       else cout << fixed << setprecision(2) << -all_num  << endl;
   }
   }
  return 0;
  }

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值