zoj--3878

Convert QWERTY to Dvorak

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward, a poor copy typist, is a user of the Dvorak Layout. But now he has only a QWERTY Keyboard with a broken Caps Lock key, so Edward never presses the broken Caps Lock key. Luckily, all the other keys on the QWERTY keyboard work well. Every day, he has a lot of documents to type. Thus he needs a converter to translate QWERTY into Dvorak. Can you help him?

The QWERTY Layout and the Dvorak Layout are in the following:

Qwerty Layout
The QWERTY Layout

Dvorak Layout
The Dvorak Layout

Input

A QWERTY document Edward typed. The document has no more than 100 kibibytes. And there are no invalid characters in the document.

Output

The Dvorak document.

Sample Input
Jgw Gqm Andpw a H.soav Patsfk f;doe
Nfk Gq.d slpt a X,dokt vdtnsaohe
Kjd yspps,glu pgld; aod yso kd;kgluZ
1234567890
`~!@#$%^&*()}"']_+-=ZQqWEwe{[\|
ANIHDYf.,bt/
ABCDEFuvwxyz
Sample Output
Hi, I'm Abel, a Dvorak Layout user.
But I've only a Qwerty keyboard.
The following lines are for testing:
1234567890
`~!@#$%^&*()+_-={}[]:"'<>,.?/\|
ABCDEFuvwxyz
AXJE>Ugk,qf;

这道题,眼睛都看花了,题目很简单,就是字符转化,一开始使用swtich来写密密麻麻的,后来居然warning,case太多什么什么的,后来看了一下人家的,用两个字符串就OK了,这方法太赞了;(注意单引号--\'      双引号\"    应该这样表示)

代码如下:

#include<stdio.h>
#include<string.h>
char s1[]={"-+QWERTYUIOP{}_=qwertyuiop[]SDFGHJKL:\"sdfghjkl;\'ZXCVBN<>zxcvbn,.?/"};
char s2[]={"[}\"<>PYFGCRL?+{]\',.pyfgcrl/=OEUIDHTNS_oeuidhtns-:QJKXBWV;qjkxbwvZz"};
char check(char c)
{
	for(int i=0;s1[i];i++)
	{
		if(s1[i]==c)
		return s2[i];
	}
	return c;
}
int main()
{
	char a;
	while(scanf("%c",&a)!=EOF)
	{
		printf("%c",check(a));
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值