Convert QWERTY to Dvorak

Edward, a poor copy typist, is a user of the Dvorak Layout. But now he has only a QWERTY Keyboard with a broken Caps Lock key, so Edward never presses the broken Caps Lock key. Luckily, all the other keys on the QWERTY keyboard work well. Every day, he has a lot of documents to type. Thus he needs a converter to translate QWERTY into Dvorak. Can you help him?

The QWERTY Layout and the Dvorak Layout are in the following:

Qwerty Layout
The QWERTY Layout

Dvorak Layout
The Dvorak Layout

Input

A QWERTY document Edward typed. The document has no more than 100 kibibytes. And there are no invalid characters in the document.

Output

The Dvorak document.

Sample Input
Jgw Gqm Andpw a H.soav Patsfk f;doe
Nfk Gq.d slpt a X,dokt vdtnsaohe
Kjd yspps,glu pgld; aod yso kd;kgluZ
1234567890
`~!@#$%^&*()}"']_+-=ZQqWEwe{[\|
ANIHDYf.,bt/
ABCDEFuvwxyz
Sample Output
Hi, I'm Abel, a Dvorak Layout user.
But I've only a Qwerty keyboard.
The following lines are for testing:
1234567890
`~!@#$%^&*()+_-={}[]:"'<>,.?/\|
ABCDEFuvwxyz
AXJE>Ugk,qf;
 
 
题意:输入第一个表的字符,输出对应下表的字符
思路:打表
#include<stdio.h>
#include<string.h>
char str[96][2]={ 
{'-','['},{'_','{'},{'+','}'},{'=',']'},{'Q','"'},
{'q','\''},{'W','<'},{'w',','},{'E','>'},{'e','.'},
{'R','P'},{'r','p'},{'T','Y'},{'t','y'},{'Y','F'},
{'y','f'},{'U','G'},{'u','g'},{'I','C'},{'i','c'},
{'O','R'},{'o','r'},{'P','L'},{'p','l'},{'{','?'},
{'[','/'},{'}','+'},{']','='},{'S','O'},{'s','o'},
{'D','E'},{'d','e'},{'F','U'},{'f','u'},{'G','I'},
{'g','i'},{'H','D'},{'h','d'},{'J','H'},{'j','h'},
{'K','T'},{'k','t'},{'L','N'},{'l','n'},{':','S'},
{';','s'},{'"','_'},{'\'','-'},{'Z',':'},{'z',';'},
{'X','Q'},{'x','q'},{'C','J'},{'c','j'},{'V','K'},
{'v','k'},{'B','X'},{'b','x'},{'N','B'},{'n','b'},
{'<','W'},{',','w'},{'>','V'},{'.','v'},{'?','Z'},
{'/','z'},{'~','~'},{'`','`'},{'!','!'},{'1','1'},
{'@','@'},{'2','2'},{'#','#'},{'3','3'},{'$','$'},
{'4','4'},{'%','%'},{'5','5'},{'^','^'},{'6','6'},
{'&','&'},{'7','7'},{'*','*'},{'8','8'},{'(','('},
{'9','9'},{')',')'},{'0','0'},{'M','M'},{'m','m'},
{'A','A'},{'a','a'}, {'|','|'},{'\\','\\'},{' ',' '}            
             };

int main()
{
  char s[102500];
  int i,j;
  while(gets(s))
  {
    int len=strlen(s);              
     for(i=0;i<len;i++)
     {
       for(j=0;j<96;j++)
       if(s[i]==str[j][0]) printf("%c",str[j][1]);                  
     }
     printf("\n");
  }    
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值