poj--2406

                                                    Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 38544 Accepted: 16001
Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input

abcd
aaaa
ababab
.
Sample Output

1
4

3

题目来源:http://poj.org/problem?id=2406

考查点:Kmp中next数组的应用

参考资料:http://www.cnblogs.com/jackge/archive/2013/01/05/2846006.html

代码如下:

#include<stdio.h>
#include<string.h>
char a[1000010];
int per[1000010];
int b[1000010];
int l;
void getp()
{
	int i,j;
	j=-1;i=0;
	per[i]=-1;
	while(i<l)
	{
		if(j==-1||a[i]==a[j])
		{
			i++;
			j++;
			per[i]=j;
		}
		else j=per[j];
	}
}
int main()
{
	while(scanf("%s",a))
	{
		if(strcmp(a,".")==0)break;
		l=strlen(a);
		memset(per,0,sizeof(per));
	    getp();
	    if(l%(l-per[l])==0)
	    printf("%d\n",l/(l-per[l]));
	    else printf("1\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值