hdu--3284

Adjacent Bit Counts

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 378    Accepted Submission(s): 308


Problem Description
For a string of n bits x 1, x 2, x 3, …, x n, the adjacent bit count of the string ( AdjBC(x)) is given by

x1*x2 + x2*x3 + x3*x4 + … + xn-1*xn

which counts the number of times a 1 bit is adjacent to another 1 bit. For example:

AdjBC(011101101) = 3
AdjBC(111101101) = 4
AdjBC(010101010) = 0

Write a program which takes as input integers n and k and returns the number of bit strings x of n bits (out of 2 n) that satisfy AdjBC(x) = k. For example, for 5 bit strings, there are 6 ways of getting
AdjBC(x) = 2:

11100, 01110, 00111, 10111, 11101, 11011
 

Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. Each data set is a single line that contains the data set number, followed by a space, followed by a decimal integer giving the number (n) of bits in the bit strings, followed by a single space, followed by a decimal integer (k) giving the desired adjacent bit count. The number of bits (n) will not be greater than 100 and the parameters n and k will be chosen so that the result will fit in a signed 32-bit integer.
 

Output
For each data set there is one line of output. It contains the data set number followed by a single space, followed by the number of n-bit strings with adjacent bit count equal to k.
 

Sample Input
  
  
10 1 5 2 2 20 8 3 30 17 4 40 24 5 50 37 6 60 52 7 70 59 8 80 73 9 90 84 10 100 90
 

Sample Output
  
  
1 6 2 63426 3 1861225 4 168212501 5 44874764 6 160916 7 22937308 8 99167 9 15476 10 23076518
 

Source

解体思路:简单的dp,想了很久也没想到,感觉dp好强大.得好好花点功夫学习

代码如下:
#include<stdio.h>
int dp[110][110][2];//d[i][j][k]表示长度为i的串,权值为j时,以k=(1 or 0)为尾时的方法数 
int main(){
	int t,l,p,cas;
	dp[1][0][0]=dp[1][0][1]=1;
	for(int i=2;i<=100;i++){
		dp[i][0][0]=dp[i-1][0][0]+dp[i-1][0][1];
	    dp[i][0][1]=dp[i-1][0][0];
	    for(int j=1;j<i;j++){
	    	dp[i][j][0]=dp[i-1][j][1]+dp[i-1][j][0];
	    	dp[i][j][1]=dp[i-1][j-1][1]+dp[i-1][j][0];
	    }
	}
	scanf("%d",&t);
	while(t--){
		scanf("%d%d%d",&cas,&l,&p);
	    printf("%d %d\n",cas,dp[l][p][0]+dp[l][p][1]);
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值