POJ 1386-Play on Words(有向欧拉通路)

Play on Words
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11744 Accepted: 4016

Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

Source


题目意思:

读入一组单词,判断是否可以重新排序使得每个单词的第一个字母与前一个单词的最后一个字母相同。

解题思路:

构造有向图,顶点为26个字母,每个单词为一条边,判断图中是否存在一条路径经过每条边有且仅且一次。
这就是有向欧拉通路。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <iomanip>
#include <algorithm>
#define maxn 100010
#define INF 0xfffffff
using namespace std;
int t,n;
char word[1001];//读入的单词
int od[26],id[26];//每个字母表示的顶点的出度和入度
int bused[26];//bused[i]表示第i个字母在单词中是否作为首位字母
int parent[26];//parent[i]表示顶点i所在集合对应的树中的根结点
struct Edges//边
{
    int u,v;//边上的两个顶点
} edge[maxn];
void ufset()
{
    for(int i=0; i<26; ++i)
        parent[i]=-1;
}
int Find(int x)//查找并返回节点x所属集合的根结点
{
    int i;//查找到的位置
    for(i=x; parent[i]>=0; i=parent[i]);
    while(i!=x)//路径压缩
    {
        int tmp=parent[x];
        parent[x]=i;
        x=tmp;
    }
    return i;
}
void Union(int X,int Y)//合并两个不同集合的元素,使得两个集合中任意两个元素都连通
{
    int x=Find(X),y=Find(Y);//x是X的根结点,y是Y的根结点
    int tmp=parent[x]+parent[y];//两个集合节点个数之和(负数)
    if(parent[x]>parent[y])//parent[x]是负数
    {
        parent[x]=y;
        parent[y]=tmp;
    }
    else
    {
        parent[y]=x;
        parent[x]=tmp;
    }
}
bool Connect()//判断有向图的基图是否连通
{
    int u,v,i;
    ufset();
    for(i=0; i<n; ++i)
    {
        u=edge[i].u;//如果边(u,v)不属于同一个连通分量,则合并
        v=edge[i].v;
        if(u!=v&&Find(u)!=Find(v))
            Union(u,v);
    }
    int first=-1;//第一个bused[i]不为0的顶点
    for(i=0; i<26; ++i)
    {
        if(bused[i]==0) continue;
        if(first==-1) first=i;
        else if(Find(i)!=Find(first)) break;
    }
    if(i<26) return false;
    else return true;
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int u,v;
    int i,j;
    cin>>t;
    for(i=0; i<t; ++i)
    {
        memset(od,0,sizeof(od));
        memset(id,0,sizeof(id));
        memset(bused,0,sizeof(bused));
        cin>>n;
        for(j=0; j<n; ++j)
        {
            cin>>word;
            u=int(word[0])-'a';//首字母
            v=int(word[strlen(word)-1])-'a';//尾字母
            ++od[u],++id[v];
            bused[u]=bused[v]=1;
            edge[j].u=u,edge[j].v=v;
        }
        bool euler=true;//是否存在欧拉通路
        int one=0,none=0;//出度比入度多1的顶点个数、入度比出度多1的顶点个数
        for(j=0; j<26; ++j)
        {
            if(bused[j]==0) continue;
            if(od[j]-id[j]>=2||id[j]-od[j]>=2)
            {
                euler=false;
                break;
            }
            if(od[j]==0&&id[j]==0)
            {
                euler=false;
                break;
            }
            if(od[j]-id[j]==1)
            {
                ++one;
                if(one>1)
                {
                    euler=false;
                    break;
                }
            }
            if(id[j]-od[j]==1)
            {
                ++none;
                if(none>1)
                {
                    euler=false;
                    break;
                }
            }
        }
        if(one!=none) euler=false;
        if(!Connect()) euler=false;
        if(euler) puts("Ordering is possible.");
        else puts("The door cannot be opened.");
    }
    return 0;
}
/*
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值